How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Anthony Your Own Question
Anthony
Anthony, ASE Certified Technician
Category: Audi
Satisfied Customers: 11750
Experience:  ASE Master Automobile Technician with over 20 years exp. in this field.
15218643
Type Your Audi Question Here...
Anthony is online now
A new question is answered every 9 seconds

Audi TT: I have an Audi TT 2001 5 speed engine type ATC with

This answer was rated:

I have an Audi TT 2001 5 speed engine type ATC with an engine light on. Says I need a new MAF. I was given a part number 06A906461DX is this right. Also could the problem be an air leak? How would one check for an air leak before getting a new MAF???
Hello! Welcome to justanswer!

What code do you have that makes you think the maf is bad?
Customer: replied 3 years ago.


I am sorry I had it written down and now I do not have the code. I would be guessing but the code specifically said MAF sensor. It was the only code I got. I have turned off the engine light several times now and it just keeps coming back on. Twice we have checked the code and twice it gave us the same code. It does not ideal smoothly and I am loosing power when accelerating and gets very bad if I down shift and accelerate quickly to go around someone.


 


Please do not forget the second question regarding the clutch also.

Ok, if the code pointed right to the maf, that would mean you need to replace it. the part number you have is right.

As for the TOB, almost always they squeal real loud when you push on the clutch pedal. If its squealing every time you push on the pedal then its the problem.
Customer: replied 3 years ago.

Again it is not making the noise when pressing the clutch in. It makes the loud squealing noise as I am RELEASING the clutch pedal in reverse and a little amount when I first start releasing in first gear but not as bad. One mechanic after taking it out said he thought something in the brakes were hanging up. Since I use the brake just prior to using the reverse gear and/or the first gear, could this not be a valid problem.


Besides the MAF filter should the car also be checked for leaks and is that something that needs to be done through a garage that has the equipment??

If you could give me the code number, I can tell if its the MAF or not. Is there any way you can get the code?
Customer: replied 3 years ago.


I believe the code was a P1128


 


Any other thoughts regarding the clutch as I mentioned above the noise is on releasing not pressing the clutch in.

Ok, I can't hear the noise in the clutch to give an accurate assessment of what it is. The only tell tale sign of a bad TOB is a constant screech with clutch pedal pushed. Since your noise is different, i cant say for sure.

As for the code and the MAF, I can. Theres only two reasons for the code.

A bad MAF which needs to be replaced.

Or a vacuum leak in the intake pipes. The right way to test that is by having a smoke test done on the pipes by a shop. Its an hour job and finds a leak right away. If there is a leak, have it fixed. If there is no leak then go ahead with changing the MAF.
Customer: replied 3 years ago.


I got it on the MAF and will decide what to do with that.


 


Regarding clutch the noise is made as the clutch is being released while I am in reverse for the whole time I am releasing it. After it is fully released no noise. Push the clutch down, no noise until I am releasing it. It does not make the noise at all when the clutch pedal is just pushed in. Again is makes the noise as the clutch is released. It is not a knocking noise or a dull noise it is a high pitched squealing noise that almost goes right through you like nails on a chalk board.

If the car is stopped, can you make this noise while the car is in neutral and running?
Customer: replied 3 years ago.


I just went out and tried it, no it does not make the noise in neutral

Thats not the TOB. It would have to be something else. I cant tell from here what the noise is as I cant hear it.
Customer: replied 3 years ago.


ok, understand. Thanks for trying.

You are welcome.
Anthony and other Audi Specialists are ready to help you

Related Audi Questions