How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Wolfgang Your Own Question
Wolfgang
Wolfgang, Audi master tech
Category: Audi
Satisfied Customers: 4215
Experience:  Senior Audi Master Tech 15 yrs
19871424
Type Your Audi Question Here...
Wolfgang is online now
A new question is answered every 9 seconds

2000 Audi A4: I have pulled a P0411 engine code..Quattro..inj..flow

Resolved Question:

I have pulled a P0411 engine code from my 2000 Audi A4 1.8T Quattro (Secondary air inj. syst. incorrect flow detected? Input on what that might be? It came on around noon today, but I have not noticed any change in the engine running or performance.
Submitted: 5 years ago.
Category: Audi
Expert:  Wolfgang replied 5 years ago.
Hello there

This code can be 3 things wrong

There is a broken vacuum line to the air valve back of the cylinder head near the fire wall

The air valve itself will not open at all either frozen or the diaphragm is ruptured

Last the air pump is not working due to fuse blown because the air pump is using too much amps which then the fuse and pump needs to be replaced

The fuse is in the black box drivers side near the wipers

Do you hear at first start up a sound like a vacuum cleaner operating?

Let me know
Customer: replied 5 years ago.
Yes, I have had the noise that sounds like a vacuum when it first starts since I bought the car (3+ years). I assumed that was normal. I don't know if I still have it since the light came on, as I would have only started the car once, at work coming home. What does the pump do?
Expert:  Wolfgang replied 5 years ago.
The pump injects air the exhaust for emissions

If the pump was loud that means the pump is failing

But it may be the valve or and hose also.

So we need to verify cold engine start up and see if the pump at least works first

If warm engine then let's do a visual check on the hose

Usually breaks at the valve because it has a drastic bend to go under the intake manifold

Let's start there first
Wolfgang and 2 other Audi Specialists are ready to help you
Customer: replied 5 years ago.
Where is the pump located? I wouldn't say that the pump was louder this morning when I started it than any other time. It has been about two hours since the car was running, it is about 50 degrees here. Do you want me to start it to see if the pump runs? If it does, then look for a break in the hose?
Expert:  Wolfgang replied 5 years ago.

sure the pump is located rh side of the vehicle under the air filter area!!

 

try it and see!!

Customer: replied 5 years ago.
Give me a few minutes to complete. It sounds like the valve is directly behind the engine on the firewall? I will respond shortly.
Expert:  Wolfgang replied 5 years ago.

on the back of the head near the firewall not on the fire wall!!

 

Related Audi Questions