How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Matt Your Own Question
Matt
Matt, Engineer
Category: Audi
Satisfied Customers: 20605
Experience:  Mechanical Engineer with 20 years experience in the auto industry, 8 yrs in formula 1 engine testing
12772297
Type Your Audi Question Here...
Matt is online now
A new question is answered every 9 seconds

Audi A3 My O7 A3 TDi wont start turns over but wont start,

Resolved Question:

My O7 A3 TDi wont start turns over but wont start, oil pressure warning light comes on but oil levels appear fine.
Submitted: 5 years ago.
Category: Audi
Expert:  Matt replied 5 years ago.
Hello

I'd check that you're getting full power to the glow-plugs, they pull a lot of current so take care when checking but see if the relay is clicking when the ignition is turned on first and also check the fuse if this is OK check to see if the engine earth strap is also OK.

If the plugs haven't been changed in the last 20K then they may have to be replaced.
You can test the glow-plugs with a multimeter by measuring the resistance across the plug ( between the power connection and the body) it should be around 4-8ohms if its tending to infinity / open circuit the plug is faulty or by using a clip on current clamp, either on the supply wire to glow plugs or onto engine earth, with glow plug light on you should see 15-20amps for each glow plug fitted, 4 cylinders would be approximately 60-80amps.

Also its worth checking that the electric pump that feeds the main fuel pump is working correctly, it should run for a few seconds then switch off when you first turn the ignition on. If the connections to this are corroded or damaged then the pump could stop at any time. Check that its relay switches in and out and the relay contacts are clean and bright – replace the relay if in any doubt and do the same for the fuse, ideally measure the voltage at the pump and check its getting 12V
Also if its not injecting at all then check the connections to the crankshaft sensor, unplug it and check for corroded contacts and broken wiring, and consider fitting a new sensor - do the same for the cam position sensor
If the EGR valve is stuck open then this too can effect starting so try disconnecting it to see if this helps or changes anything
Lastly it’s also worth considering fitting a new fuel filter as if only slightly blocked this can lower fuel supply pressure and choke the main pump, the pump will be more sensitive to this when its cold as diesel thickens considerably with low temperatures.
Matt and 2 other Audi Specialists are ready to help you

Related Audi Questions