How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask John Your Own Question
John
John, Home Appliance Technician
Category: Appliance
Satisfied Customers: 13453
Experience:  Appliance repair business owner for over 43 years.
12064207
Type Your Appliance Question Here...
John is online now
A new question is answered every 9 seconds

My ovens wont heat to temp i use propane i have 2 stoves

Customer Question

my ovens wont heat to temp i use propane i have 2 stoves side by side
JA: What's the make and model of your oven? And can you guesstimate how old it is?
Customer: i bought them last july 2015
JA: Do you plan on doing the work yourself?
Customer: if its easy
JA: Anything else we should know to help you best?
Customer: no
Submitted: 1 month ago.
Category: Appliance
Expert:  Kelly replied 1 month ago.

Thanks for counting on us to help with your appliance problem. My name is ***** ***** I look forward to helping you!

Expert:  Kelly replied 1 month ago.

May I please have your model number so I am able to provide you with accurate, model specific information?

Customer: replied 1 month ago.
Expert:  Kelly replied 1 month ago.

Were the ovens converted to LP? Did they stop working or have not worked well since installed?

Customer: replied 1 month ago.
thay worked fine all summer
Expert:  Kelly replied 1 month ago.

So now they just take a long time to heat up?

Expert:  Kelly replied 1 month ago.

Or, do they heat up okay but just not accurate?

Customer: replied 1 month ago.
it takes a long time to get up to 100 degrees at least half hour
Expert:  Kelly replied 1 month ago.

You likely have a weak igniter that is slow to open or not opening all the way the gas valves, a very common issue. Are both ovens having the same issue?

Related Appliance Questions