How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Webb-Guy Your Own Question
Webb-Guy
Webb-Guy, Home Appliance Technician
Category: Appliance
Satisfied Customers: 931
Experience:  maitenance tech at casto
95800582
Type Your Appliance Question Here...
Webb-Guy is online now
A new question is answered every 9 seconds

My Kenmore 790 electric range lost all power while I had the

Customer Question

Hi. My Kenmore 790 electric range lost all power while I had the oven preheating and 2 burners on. I've flipped the breaker, still nothing. I pulled it out and checked the plug connection, it was fine. I unplugged it briefly and plugged it back in, still nothing. What should I try next? Please help!
Thank you,
Lisa
Submitted: 1 month ago.
Category: Appliance
Expert:  Webb-Guy replied 1 month ago.

Hello and welcome to just answer my name is ***** ***** I will be the one to assist you. It sounds like the problem is your control board has went out and is going to need replaced. Do you have the model number of your kenmore so I can try and pull up some information for you?

Expert:  Webb-Guy replied 1 month ago.

Are you still with me?

Related Appliance Questions