How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Appliance Guru Your Own Question
Appliance Guru
Appliance Guru, Owner and Technician
Category: Appliance
Satisfied Customers: 13984
Experience:  Over 15 yrs. experience with 10,000+ in home repairs.
21107370
Type Your Appliance Question Here...
Appliance Guru is online now
A new question is answered every 9 seconds

Installing a middle you Marshall ps200.. It it running

Customer Question

Installing a middle you Marshall ps200.. It it running yesterday.. Today no power to unit.. But there is power to the unit
Submitted: 2 months ago.
Category: Appliance
Expert:  Appliance Guru replied 2 months ago.

One moment while I get some information for you!

Expert:  Appliance Guru replied 2 months ago.

Hello and thanks for using this service! If you are a JA Member I would like to personally thank you and welcome you back! I am Appliance Guru an extremely experienced tech on the site and I try to get to as many customers as I can. NOTE it takes time for me to type research and add links so please wait for me to respond back I can only do this so fast. Secondly, I do not know your skill level so please try and let me know if I am going beyond your knowledge or comfort zone thanks! I strive for a 5 star rating from everyone especially our JA members.

Answer:

Have you checked the 3 fuses in the control console?

Customer: replied 2 months ago.
There is power to the unit.. At the main supply. There is power going into the unit.. I can bypass the main to power on the fans.. But the main control won't come on
Expert:  Appliance Guru replied 2 months ago.

Have you checked the internal fuses if one is out the control will not come on

Customer: replied 2 months ago.
I am guessing you are getting nowhere. Thanks anyways
Customer: replied 2 months ago.
Not sure how we are on two different windows of messaging .. Yes I have checked the fuses.. All three are good
Expert:  Appliance Guru replied 2 months ago.

Have you checked those fuses or not?

Customer: replied 2 months ago.
They are all good
Expert:  Appliance Guru replied 2 months ago.

HAve you checked the two to the transformer as well?

Expert:  Appliance Guru replied 2 months ago.

Those will kill power to the low voltage control

Customer: replied 2 months ago.
Can you tell me where they are?
Expert:  Appliance Guru replied 2 months ago.

Did you check these

Click

Customer: replied 2 months ago.
These are the same ones we checked in the beginning
Expert:  Appliance Guru replied 2 months ago.

CLICK HERE

Check that one

All I ask is please use the Star Rating Link at the top of your page before leaving, that is the only way I am paid anything through the site and that will also get you a DIRECT LINK emailed to you to get back to me!.....tips are greatly appreciated so thank you very much for using this service. If you have any other questions just post back to me here anytime!

Related Appliance Questions