How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Kelly Your Own Question
Kelly
Kelly, Appliance Technician
Category: Appliance
Satisfied Customers: 20777
Experience:  Highly accurate diagnostician with over 30 years experience!
11418111
Type Your Appliance Question Here...
Kelly is online now
A new question is answered every 9 seconds

From Keller Appliance, Model # KDRS483VSS00 I am trying to

Customer Question

Hello, this is Bill from Keller Appliance,
Model # KDRS483VSS00
I am trying to get a KitchenAid Pro style range fixed to use in my home. It's previous owner got it with parts missing: the burner caps, the griddle, the griddle temperature probe, the griddle heating element, as well as the burner grates.
It has been displaying the F1E1 error code within a minute of plugging in the machine. We have since replaced one of the two control boards (it uses 2 of the same board) in the range but the problem has not gone away. After clearing the code by pressing the off button, the code returns within 30-60 seconds. The display seems to suggest that the problem is with the left side oven but even after switching the new board's placement with that of the second, used, board, the problem remains and it does not say that the left side oven is the problem. We have verified the voltage to the machine many times, we also have a temperature probe and an element plugged in for the griddle now.
What steps can we take to confirm where the problem might be and how we can fix it?
Submitted: 7 months ago.
Category: Appliance
Expert:  Kelly replied 7 months ago.

Thanks for counting on us to help with your appliance problem. My name is ***** ***** I look forward to helping you!

Expert:  Kelly replied 7 months ago.

That error is very specific to the Appliance Manager board. Are the door switches working and not shorted or otherwise having issues?

Customer: replied 7 months ago.

I believe he already checked, but I will have the door switches double checked.

Expert:  Kelly replied 7 months ago.

That really is the only other thing that will cause that error other than the board failure.

Customer: replied 7 months ago.

Would this unit need to have both boards replaced? it uses two identical boards and we replaced one of them? I will let you know as soon as I can get the door switches checked

Expert:  Kelly replied 7 months ago.

Not to correct only one that is failing, have you tried the new control for the other oven?

Customer: replied 7 months ago.

Yes we have tried switching the new board's placement. and doing so had no appreciable effect on our issue.

The oven lights shut on and off as they should when the door is opened and closed, my associate tells me that there are only two wires to each door switch.

Expert:  Kelly replied 7 months ago.

Correct, so they are working. It may be an issue with one of the interface controls that is making the appliance manager error. What happens if you disconnect one of the interface cables and then the other? Any change in the behavior?

Customer: replied 7 months ago.

we had put in a new interface at first but it changed nothing, so we sent it back. we then tried replacing one of the two control boards. the interface seems to connect to both boards.

Expert:  Kelly replied 7 months ago.

That is going to be difficult to track down then because if something is causing an issue with the AM board when plugged in, it will be very difficult to find.

Customer: replied 7 months ago.

This range is worth $10k so we are very interested in getting it fixed, we are happy to give a large tip on this if we succeed, we trust your opinion. Where in your opinion should we check? We are going to look into the door lock and double check switches.

Expert:  Kelly replied 7 months ago.

Does the display show what side the error is on, for which oven I mean?

Customer: replied 7 months ago.

it seems to consistently indicate the left side, in one of the diagnostic modes it says that the right side is "Good" but flashes the error code when we press the button for the left side oven.

Expert:  Kelly replied 7 months ago.

What I would do is unplug one load connector from the AM board at a time and plug the range in. If you unplug one and the error does not come on, that will give you an idea which circuit is having issues.

Customer: replied 7 months ago.

which connector is the load?

Expert:  Kelly replied 7 months ago.

All of the connectors on that board, the P8, P1, P2, etc

Customer: replied 7 months ago.

My tech just told me that he did and the machine prompts a communication error.

Expert:  Kelly replied 7 months ago.

Hmm, it sounds like that board is faulty. Did you install a new one or one you had around?

Customer: replied 7 months ago.

one new one, but the other original remained in the machine.

Expert:  Kelly replied 7 months ago.

I would be tempted to replace the other board, too. However, I would order it from Repair Clinic so you cab return it if you still have issues. This is a very atypical failure and it seems that all logical testing has been done.

Customer: replied 7 months ago.

Okay, we are working on checking over several of the components or checking them again more thoroughly

Expert:  Kelly replied 7 months ago.

Okay, keep me posted. Thanks, Bill!