How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask John Your Own Question
John, Home Appliance Technician
Category: Appliance
Satisfied Customers: 13453
Experience:  Appliance repair business owner for over 43 years.
Type Your Appliance Question Here...
John is online now
A new question is answered every 9 seconds

We have a 2 year old GE induction range model PHB920SF1SS

Customer Question

We have a 2 year old GE induction range model PHB920SF1SS the cook top keeps shutting down. When it does this it will also shut down the oven if it is in use. We are using using approved pots etc. We had a technician check it out and he could not determine what the problem is. The power to the range is okay.
Submitted: 3 months ago.
Category: Appliance
Expert:  Kelly replied 3 months ago.

Hi, welcome to Just Answer. My name is ***** ***** I look forward to helping you!

Please know that I am not compensated for my time by the site until you rate using the stars at the top of your page. A rating is appreciated once we get to the solution for your appliance issue, thanks!

  1. Does it ever shut down when just using the oven?
  2. Any error codes or flashing lights?
  3. How do you get it working again?
Customer: replied 3 months ago.
1. No
2. Only once in a while not always. On ocassion it will flash 90 which I think means call a serviceman. We had one look at it and they were unable to help.
3. Most the time I have to switch the main electrical break.
You have a file on me as I spoke to you last week and was looking for a oven sensor which I have now replaced without success
Expert:  Kelly replied 3 months ago.

Thank you. The oven sensor would not affect the induction part of the range. It is likely a problem in the induction electronics. Did you ever run a diagnostic cycle to see if there were any issues showing?

Related Appliance Questions