How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Appliance Guru Your Own Question
Appliance Guru
Appliance Guru, Owner and Technician
Category: Appliance
Satisfied Customers: 13404
Experience:  Over 15 yrs. experience with 10,000+ in home repairs.
Type Your Appliance Question Here...
Appliance Guru is online now
A new question is answered every 9 seconds

I have a whirlpool electric oven model WCW30502. All of a sudden

Customer Question

I have a whirlpool electric oven model WCW30502. All of a sudden both the broiler and oven elements are not starting. I cannot see both elements going at once. The display panel has power and the panel shows the regular display when I switch it to bake or broil. I can the usual click sound which normally indicates the oven or broiler heating element has started. But there is no heat.
Submitted: 6 months ago.
Category: Appliance
Expert:  Appliance Guru replied 6 months ago.
Hello and thanks for using this service, if you have been waiting do not worry or get upset. I am Appliance Guru an extremely experienced tech on the site and I try to get to as many customers as I can. I just picked up your question now. Can you double check that model it does not come up valid?
Customer: replied 6 months ago.
Checked again. That is the model number. Vintage is about 1997.
Expert:  Appliance Guru replied 6 months ago.
Something is not right with the model it does not come up on any lookup and is not right based on my experience either the first letters look ok but there is something with 30502
Expert:  Appliance Guru replied 6 months ago.
Can you take a picture of it and upload it?
Customer: replied 6 months ago.
I attached a photo
Customer: replied 6 months ago.
Sorry, going to bed instead.
Expert:  Appliance Guru replied 6 months ago.
AHHHH it's a Canadian Model....that is the issue. Well either the door latch switch is bad as that can cut power to the heating ciruit, you lost a leg of power to the unit or the high limit thermostat is tripped open. You need to check the power to the unit first where the cord connects to it for full 240 volts power. Then check the high limit thermostat then the door latch. All I ask is please use the Star Rating Link at the top of your page before leaving, tips are greatly appreciated so thank you very much for using this service. If you have any other questions just post back to me here anytime!

Related Appliance Questions