How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask John Your Own Question
John, Home Appliance Technician
Category: Appliance
Satisfied Customers: 13453
Experience:  Appliance repair business owner for over 43 years.
Type Your Appliance Question Here...
John is online now
A new question is answered every 9 seconds

Got a strange problem. Have a whirlpool oven (built in) that

Customer Question

Good morning, got a strange problem. Have a whirlpool oven (built in) that we just put in a rebuilt control board. The problem was that the oven was staying on (on low temp) even as it was shut off. Now, with the new board it is still doing the same thing. Any ideas? Mod. GBD307PDB7
Submitted: 7 months ago.
Category: Appliance
Expert:  Whrlp Master Tech replied 7 months ago.

Hello from Just Answer and the Appliance Catigory
My name is Woody.
I will be glad to assist you today.
I have been servicing ALL Major Brands of Appliances for 36 Years, I own my own Appliance repair Company
And I teach appliance repair at a local Community College.
I have over 100,000 plus in home repairs and over 80,000 internet repairs under my belt.
You will be paying me for my ANSWER to your Appliance Question,, Not for the repair of your appliance hence the name of this site Just Answer.
I will do my best to take the information that you provide to me and make a Diagnosis for you to be able to repair your own Appliance.

Do you have a Volt-Ohm meter and know how to use it ? to be able to do any testing ?

And can you tell is it the upper oven Broil element or the lower Bake element that is giving off heat?

Customer: replied 7 months ago.
I have a meter, we actually have two problems. One is that it won't shut off and second one is that when we go to turn on either the top or lower oven, and put on bake, only the broil element comes on
Customer: replied 7 months ago.
Both bake element don't come on properly, one time the bottom bake came on but next time it did not
Expert:  Whrlp Master Tech replied 7 months ago.

ok to be sure your saying that both ovens upper and lower that the bake element do not work ?

And this is a brand new control board?

what is the part number of the control board that you installed?

Customer: replied 7 months ago.
We sent it out to Core centric the part is(###) ###-####
Expert:  Whrlp Master Tech replied 7 months ago.

Ok is that company the one in Chicago?

And was this the same thing that was happening before you sent the board out to them?

Customer: replied 7 months ago.
it's the Chicago company and yes, exact same thing
Customer: replied 7 months ago.
Usually I have had success with that company,
Expert:  Whrlp Master Tech replied 7 months ago.

ok can you open the console and gain access to the rear of the control board for testing?

The control board is the only common denominator for the upper and lower Bake elements each is controlled by a separate relay on the control board.

Customer: replied 7 months ago.
I can open up that panel, the board is fairly accessible. You mean you want to test the board itself? So it's mostly we got a bum back from the factory?
Expert:  Whrlp Master Tech replied 7 months ago.

Yes has to be wire off or the control board on the not heating in the Bake mode

and if the wire is shorted to ground it would make the element heat when the oven it not on but only at 1/2 the normal voltage.

We can test both from the wiring on the control board.

Customer: replied 7 months ago.
Ok bro got to go to work, will check back when get back later
Expert:  Whrlp Master Tech replied 7 months ago.

Ok can you read a wiring diagram I will send you one if you can?

Expert:  Whrlp Master Tech replied 7 months ago.

I will send one to you incase you can read it.

Remove the P18 connector and test the Red P18-4 to ground to see if you get voltage when the connector is off the control board.

And the same thing on the P 26 connector P26-4 Red to ground with the connector off the control testing it to ground looking for 120 volts on both to ground if you do not get voltage you have a wireing issue in the rear of the unit I suspest

Expert:  Whrlp Master Tech replied 6 months ago.

Do you still need assistance on your question?

Related Appliance Questions