How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask John Your Own Question
John
John, Home Appliance Technician
Category: Appliance
Satisfied Customers: 13453
Experience:  Appliance repair business owner for over 43 years.
12064207
Type Your Appliance Question Here...
John is online now
A new question is answered every 9 seconds

Working on a Thermidor wall oven microwave combo

Customer Question

Working on a Thermidor wall oven microwave combo CM302US...replaced micro components....capacitor, diode and transformer and now display is not coming on
Submitted: 8 months ago.
Category: Appliance
Expert:  Whrlp Master Tech replied 8 months ago.

Hello from Just Answer and the Appliance Catigory
My name is Woody.
I will be glad to assist you today.
I have been servicing ALL Major Brands of Appliances for 36 Years, I own my own Appliance repair Company
And I teach appliance repair at a local Community College.
I have over 100,000 plus in home repairs and over 80,000 internet repairs under my belt.
You will be paying me for my ANSWER to your Appliance Question,, Not for the repair of your appliance hence the name of this site Just Answer.
I will do my best to take the information that you provide to me and make a Diagnosis for you to be able to repair your own Appliance.

look to see if you have a loose or wire off the control board .

I assume that the unit had a display before you opened it up is that correct?

Customer: replied 8 months ago.
Correct
Customer: replied 8 months ago.
Checking now...
Expert:  Whrlp Master Tech replied 8 months ago.

ok so for it to not have power to bring the display up ,you would have had to of knocked some thing loose .

None of the High side components would have an effect one the display .

Check the magtube thermostat also it could kill the display and it sounds as if you were working right around it.

Customer: replied 8 months ago.
They seem fine...this is third time I checked them
Expert:  Whrlp Master Tech replied 8 months ago.

ok check L1 and Neutral to the control board to see if you have voltage to the control board or not?

Customer: replied 8 months ago.
Thermostat is fine
Expert:  Whrlp Master Tech replied 8 months ago.

if not then test L1 to ground and see if you have voltage if not back track L1 to see where you have lost it at .

Customer: replied 8 months ago.
Not locating L1 ...you are talking relay board correct?
Customer: replied 8 months ago.
Hello?
Customer: replied 8 months ago.
Well I hope I am not getting charged
Expert:  Whrlp Master Tech replied 8 months ago.

the L1 id the power lead normally black going to the control board /display board .

sorry you are not the only customer that I`m assisting .

Expert:  Whrlp Master Tech replied 8 months ago.

I have not heard back from you ,did you find out what the issue was?

Customer: replied 8 months ago.
No I did not.
Expert:  Whrlp Master Tech replied 8 months ago.

Did you have voltage to the display control board?

Customer: replied 8 months ago.
Response time was unacceptable. I expect to be refunded.

Related Appliance Questions