How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Joel Swenson Your Own Question
Joel Swenson
Joel Swenson,
Category: Appliance
Satisfied Customers: 2803
Experience:  Owner at Scott's Appliance Repair
89799402
Type Your Appliance Question Here...
Joel Swenson is online now
A new question is answered every 9 seconds

I have a Thermador Fridgerator/freezer bottom mount Model

Customer Question

I have a Thermador Fridgerator/freezer bottom mount Model T361T70NNP/04 Type KIBM36DUS SERIAL # *****
MY PROBLEM IS, LIGHTS ARE ON IN REFRIGERATOR SECTION, BUT NEITHER COMPRESSOR
RUNS AND DIGITAL READ OUT IN REFRIGERATOR SECTION IS BLANK. WHY IS THIS???
Submitted: 1 year ago.
Category: Appliance
Customer: replied 1 year ago.
Posted by JustAnswer at customer's request) Hello. I would like to request the following Expert Service(s) from you: Live Phone Call. Let me know if you need more information, or send me the service offer(s) so we can proceed.
Customer: replied 1 year ago.
WE ARE STILL WAITING FOR A RESPONSE, IT HAS BEEN OVER 10 MINUTES
Expert:  Joel Swenson replied 1 year ago.

Hello, I'm Joel thank you for using JA! If you have been waiting a while
I apologize as I try to help as many customers as possible in a timely manner.

Give me just a minute and I will be right with you I am working on your answer now please be patient as I may have to look up part numbers and or refer the service manual to give you the most informative answer possible depending on your question.

Keep in mind we are on the honor system for our time so I ask that you take the time to give me a rating by clicking on the 5 star rating system before you leave today it will be available for you to click on once I have answered your request. Thank you.

Expert:  Joel Swenson replied 1 year ago.

If there is no voltage to the DPM ( display module) then the power module that provides power to that board is bad:

This board is located at the rear

Power Module

Part #: 661202

listed as 623 on the diagram below for location reference:

click here for diagram

We are on the honor system for our time so I Kindly ask you to rate my service BEFORE YOU LEAVE TODAY by clicking 3 or better on the STAR RATING SYSTEM at the top of your page.

This will also allow you to get directly back to me for FREE follow up questions.

TIPS are not expected but are GREATLY APPRECIATED!

Thank you!

Customer: replied 1 year ago.
Thank you so much. I appreciate your help. I am going to order this tomorrow. My question is, if it doesn't work, then what?
Once the board is put on, the supply house will not take the part back. I will contact you if this does not fix my problem.
Thanks,
Gene Zogleman
Expert:  Joel Swenson replied 1 year ago.

Hello Gene,

If you order the part here they take any part back for any reason for 1 year even on electronics that have been installed : click here

Although I am fairly certain this will fix the issue, unless there is some type of wiring short in the unit but in case it does not you can return it to them for a full refund, minus return shipping.

Please remember to give me a rating by clicking on the star rating system, thank you so much.