How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Kelly Your Own Question
Kelly
Kelly, Appliance Technician
Category: Appliance
Satisfied Customers: 19092
Experience:  Highly accurate diagnostician with over 30 years experience!
11418111
Type Your Appliance Question Here...
Kelly is online now
A new question is answered every 9 seconds

I have a KitchenAid KSSC36FMS01 and I just replaced the

Customer Question

Customer: I have a KitchenAid KSSC36FMS01 and I just replaced the Inverter Box, but now I get just a Green LED blinking on the inverter that blinks 4 times
JA: Thanks. Can you give me any more details about your issue?
Customer: The refrigerator just died stopped cooling. Had a repaid technician tell me I needed a new inverter box as power coming out of the main control was proper, but there was no power going out of the inverter. Still nothing, just have an LED blinking 4 times on the new inverter
JA: OK got it. Last thing — JustAnswer charges a fee (generally around $18) to post your type of question to Appliance Experts (you only pay if satisfied). There are a couple customers ahead of you. Are you willing to wait a bit?
Customer: Yes
JA: OK. Now I'm going to take you to a page to place a secure deposit with JustAnswer. Don't worry, this chat is saved. After that, we will finish helping you.
Submitted: 11 months ago.
Category: Appliance
Expert:  Joel Swenson replied 11 months ago.

Hello, I'm Joel thank you for your interest in our service. If you have been waiting a while
I apologize as I try to help as many customers as possible in a timely manner. I am now
available to help you with your question. Give me just a minute and I will be right with you working on your answer now. Thanks.

Expert:  Joel Swenson replied 11 months ago.

Ok so if you have replaced the inverter and the main board was found to be good and no fans or compressor is running then the relay board that controls the staring of the compressor, fans and defrost system is bad and needs to be replaced.

Refrigerator Electronic Control Board

Part #:(###) ###-####/a>

it's listed as part #31 on the diagram below , just to give you an idea of where it's located:

diagram

I am now working on your answer so

PLEASE take into consideration we are on the honor system for our time, I Kindly ask you to rate my service AT This Time by clicking on the STAR RATING SYSTEM at the top of your page or wherever the 5 star rating system is located on your page (sometimes it's hard to find but it's there).

Also be aware that this rating is for the quality of my response, not a rating for the overall experience you have had on this site.

Rating me will not in any way affect the amount you agreed to pay for the question. This will also allow you to get directly back to me for FREE follow up questions.

TIPS are not expected but are GREATLY APPRECIATED! Happy Holidays!

Customer: replied 11 months ago.
Okay, right now basically all fans run. We did the system diagnostics and the only thing that did not pass was the compressor. We have the proper 6 to 8 volts coming out of the control board . The weird thing is that with everything on, the inverter is only putting out 8 volts? We did a test on the compressor according to the service sheet and we are getting 6.2 ohms and the service sheet says that we should have between 6-7 ohms. Just wanted to make sure I give you as much information as possible.
Expert:  Joel Swenson replied 11 months ago.

Ok so here is the deal, the compressor has 3 pins on it so you would need to have 6-7 ohms between each pin connection so you need to check all not just two, so check all combinations of pin connections for each pin on the compressor and I bet you find that you do not have the proper ohms, meaning a bad compressor.

Customer: replied 11 months ago.
We tested all pins on the ohms, they all tested at 6.2 ohms.
Customer: replied 11 months ago.
I am not exactly sure what the green blinking LED on the new inverter is all about - when we have it all hooked up the light will blink 4 times and if we disconnect the compressor lead it will blink 3 times. It is an Embarco inverter, but there is nothing anywhere that I can find that will tell me what the LED blinking diagnostic codes are.
Customer: replied 11 months ago.
Sorry - will the compressor run if the unit is out of Freon? It seems to me that either the unit is out of freon or the compressor is froze up. I could be completely wrong and you know more about this than I do!!
Expert:  Joel Swenson replied 11 months ago.

yes the compressor would still run even if the system was low on freon. So at this point I am at a loss and will have to opt out maybe another tech will be of more help on this issue.

Customer: replied 11 months ago.
How do I go about getting another technician?
Expert:  Kelly replied 11 months ago.

Hi, welcome to Just Answer. My name is ***** ***** I look forward to helping you! The voltage to the inverter comes directly from the P5-2 and P5-4 connector on the board, the black and white wires on the inverter, 120 volts AC. The control voltage that turns the inverter on is only 3-6 volts AC, the red and red/white wires. Are you certain you are getting 120 VAC to the inverter on the black and white wires? If so and the control voltage is present as well, the compressor is likely faulty if the inverter has been replaced. See the attached page.

Related Appliance Questions