How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Appliance Medic Your Own Question
Appliance Medic
Appliance Medic, Home Appliance Technician
Category: Appliance
Satisfied Customers: 10831
Experience:  Factory Trained CFC Technician
13570846
Type Your Appliance Question Here...
Appliance Medic is online now
A new question is answered every 9 seconds

My Thermador Slide-In RES30, installed in March 1999, has

Customer Question

My Thermador Slide-In RES30, installed in March 1999, has developed a problem with the oven heating system over the past two weeks. Neither the "bake" nor the "convection cycles will heat past about 200 o. The "Broil" cycle works fine; I've been reduced to heating the oven using "Broil Hi" setting, then watching what's cooking until it appears to be done.
I ran the oven test to see if the thermostat was off calibration. When I hit the "bake" button, then moved the temperature to 505 and immediately again pressed and held the "bake" button for 3-4 seconds, the screen read "00." However, when I ran the same test for the "convection" setting, the screen read "ESC o."
What can you suggest?
Lynn Wood
Submitted: 1 year ago.
Category: Appliance
Expert:  Appliance Medic replied 1 year ago.

Hi, this would indicate a faulty convection element or bake element or possibly a voltage issue. You will need a volt/ohm meter to test the elements for 220v. One of the elements is bad or the board is not sending power. Only way to test is with a meter.