How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Appliance Guru Your Own Question
Appliance Guru
Appliance Guru, Owner and Technician
Category: Appliance
Satisfied Customers: 14410
Experience:  Over 15 yrs. experience with 10,000+ in home repairs.
21107370
Type Your Appliance Question Here...
Appliance Guru is online now
A new question is answered every 9 seconds

Whirlpool Cabrio Washer Model# WTW6800WB1 Serial#c01070115.

Customer Question

Whirlpool Cabrio Washer Model# ***** Serial#c01070115. I have replaced the RPS sensor several times and seems to be getting more frequent just a few months ago now and wife can't get thru a load without F51 error and diagnostics shows F41 & F51.
I have worked thru the diagnostics cycles and it passes. When I work thru test #3 the thermistor is showing open loop at the control board. Can I check the thermistor pins on the RPS sensor to see if it is the thermistor or the wiring? Wife wants me to give up on the washer and get something different, but other than this we are happy with the washer and dryer?
Submitted: 1 year ago.
Category: Appliance
Expert:  Appliance Guru replied 1 year ago.

Hello and thanks for using this service, if you have been waiting do not worry or get upset I am just one of the techs on here and I try to get to as many customers as I can and I just picked up your question now. Please give me time to respond sometimes I get your replies late so there may be a significant delay in responses. Please be patient and often I will ask you questions to narrow down the issue to get is diagnosed correctly.

You can try to test it there, but you really need to replace the board in the console that is what is causing the code, this happens all the time. The F51 and F41 both are dead signs the main board is bad, often people replace the RPS for that code and it is 99% if the time the controller

CLICK HERE

We are on the honor system for our time, all I ask is please rate my service using the STAR RATING LINK on your page before you leave. If you are not happy with the service please let me know before leaving a negative rating. This is the only way I am paid or credited through the site for my time. This will also allow you to get directly back to me for FREE follow up questions and tips are greatly appreciated! Thanks

Customer: replied 1 year ago.
Diagnostics do not show a problem with the board and whenever I replace the RPS it starts working fine for a while? Would I need to replace the RPS with the board? Can I test the RPS/thermistor to know if it is good?
Expert:  Appliance Guru replied 1 year ago.

If you have already replaced it it would not have failed again. I have been doing this for 20 years...and I have only replaced one RPS sensor, the board always causes that failure. You will not be able to test it with a meter to get an accurate test as it would have to be running and you will not be able to do that with a regular meter anyway.

Expert:  Appliance Guru replied 1 year ago.

If you need anything else let me know, also you can always buy the part from REPAIRCLINIC.COM as they have a 1 year no hassle return policy even on boards that are installed.

We are on the honor system for our time, all I ask is please rate my service using the STAR RATING LINK on your page before you leave. If you are not happy with the service please let me know before leaving a negative rating. This is the only way I am paid or credited through the site for my time. This will also allow you to get directly back to me for FREE follow up questions and tips are greatly appreciated! Thanks