How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Kelly Your Own Question
Kelly
Kelly, Appliance Technician
Category: Appliance
Satisfied Customers: 19055
Experience:  Highly accurate diagnostician with over 30 years experience!
11418111
Type Your Appliance Question Here...
Kelly is online now
A new question is answered every 9 seconds

I have an old Viking with a recently replaced Invensys

Customer Question

I have an old Viking with a recently replaced Invensys ignition module.
The ignition module has a separate 120 volt input for each burner.
Everything works normally EXCEPT:
When one of the burners is lit, the other burner on the same side of the stove will not spark unless the originally lit burner is turned off, then it will spark immediately. Same on both sides of the stove.
It seems like the “burner lit” signal through ground from the first burner lit also is signaling that the other burner is lit, so the other burner won’t spark.
Submitted: 1 year ago.
Category: Appliance
Expert:  Kelly replied 1 year ago.
Thanks for counting on us to help with your appliance problem. My name is ***** ***** I look forward to helping you! The most common cause of spark issues is with the ceramic electrodes being cracker, poor ground to the range and a poor path from the igniter electrode to the burner base. Also, if the wiring is in rough shape or pinced, you may see that issue. Use sand paper to clean the igniter electrodes and the areas that they spark to. Any change at all?
Customer: replied 1 year ago.
did you get my reply to your email yesterday?
Expert:  Kelly replied 1 year ago.
The module you have installed has one line voltage input, one neutral input, one ground and four burner outputs. Did you sand the igniters and burners as suggested?

Related Appliance Questions