How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Rob Your Own Question
Rob
Rob, Home Appliance Technician
Category: Appliance
Satisfied Customers: 6991
Experience:  20 yrs. working for a major domestic appliance company. Numerous training programs with cities, guilds and major manufacturers.
14831508
Type Your Appliance Question Here...
Rob is online now
A new question is answered every 9 seconds

GE Slide in Gas Range, Convection. Model JGS968SEK3SS. Thought

Customer Question

GE Slide in Gas Range, Convection. Model JGS968SEK3SS. Thought the issue was the convection fan not running so I removed the control panel and control board to see if I could hear the relay for the motor clicking. It seemed to be working, but fan operation was inconsistent. I am suspecting the motor, but, when putting things back together the control panel would not work once installed.
If I hold the panel, the buttons work. If I install it (using the large nuts under the burner knobs) the buttons don't work. I only get a beep when pressing "clear/off". It's like something is coming in contact with the back of the panel when it is installed. Tried a layer of 3M super 33 elec tape on back of panel, but that did not work.
Submitted: 1 year ago.
Category: Appliance
Customer: replied 1 year ago.
It looks like I can possibly replace the fan motor, control board, and control panel and be done with it..... We are selling this house (offer in hand) and getting this fixed fast (and fixed right) is important... I sort of live out in the country and am not sure if a local appliance repair guy would be able to do much more than I am doing. Who knows, maybe I am wrong and he's seen this before....
Expert:  Rob replied 1 year ago.
Welcome, my name is ***** ***** I will be helping you with your problem today. If anything isn't clear, please just ask me.
Hello, I'm so sorry for the extended wait time. Do you still need help with this?
If so, I will try to locate some information on this for you.
Thanks Rob
Customer: replied 1 year ago.
Yes. I have not bought any parts nor contacted anyone else. Also, for some reason the sight was not accepting my Amex. It says they do accept Amex, but it would not. I had to use another card. I realize that's not your issue, but if you have a customer service team you work with for payment, please let them know. I hope I provided enough info on the issue. I look forward to working with you.
Expert:  Rob replied 1 year ago.
Hi
Thanks
I will let the site know about the Amex card, thanks.
It sounds like a loose connection on the board somewhere.
Look closely at all the wiring. Look for loose connections and any burn marks etc
As for the fan motor, these are quite susceptible to fail, so I am sure this is the issue here.
Replacement is quite straightforward.
If you need a link to the part, let me know
In the meantime, Can I ask you to take a moment and rate my responses so far? Please use the smiley faces / stars, which you should now see. Please remember you are rating me personally, not the website or the problems you have had with this machine.
This will not close your question and you can still come back to me if you need more help
Thanks
Rob
Customer: replied 1 year ago.
I figured out the Amex issue. They were blocking it as a fraud alert. It should be sorted out now.The (5 or 6?) conductor cable between the two boards is a bit loose. I will take a look at that. Is that part available to purchase on it's own?
Expert:  Rob replied 1 year ago.
Hi
That might be the problem
Might be worth trying to crimp it tighter as I dont see the part isted
For parts, see here
http://www.repairclinic.com/Shop-For-Parts/a13b3d857942/Model-JGS968SEK3SS-GE-Range-Stove-Oven-Parts
Please dont forget to rate as this is the only way I get credit for spending my time helping you.
This does NOT close the question and you can still come back to me
Rob
Customer: replied 1 year ago.
I will give that a try and let you know.
Expert:  Rob replied 1 year ago.
Hi
Thanks
OK
Rob
Customer: replied 1 year ago.
That wasn't it. There is something else going on that is causing this issue. As I lower the control panel into place, it beeps as though a button has been touched. At that point, the only button that works is clear/off. If I lift it up away from the panel, the other buttons work. The metal panel below is fastened tightly and does not appear to be touching the back of the control panel. I suspect some sort of noise issue - either being radiated from the control board below or "extra sensitivity" of the control panel above....I will try the cable connection tightening one more time. If that does not do it, I think I am stuck replacing parts unless there is some sort of diagnostic test I can perform....
Expert:  Rob replied 1 year ago.
Hi
Im afraid there is no test on this model
Very strange !!
Rob

Related Appliance Questions