How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Appliance Medic Your Own Question
Appliance Medic
Appliance Medic, Home Appliance Technician
Category: Appliance
Satisfied Customers: 10831
Experience:  Factory Trained CFC Technician
13570846
Type Your Appliance Question Here...
Appliance Medic is online now
A new question is answered every 9 seconds

Kelly, just replaced heater element, high temp thermostat

Customer Question

Hi Kelly, just replaced heater element, high temp thermostat and door vent, still not drying on my frigidaire dishwasher. Thanks, Paul
Submitted: 1 year ago.
Category: Appliance
Expert:  Appliance Medic replied 1 year ago.
Welcome and thank you for your question. I will be the professional that will be assisting you.
Hi Paul, the control board is going to be the culprit. Unfortunately, the control board will need to be replaced to fix this issue. The board is the last thing left in the equation.
You need to order and replace part number###-##-####to fix this issue. Double check the connections on the board. One of them could be loose but you will find the board is shorted.
We work on the honor system here at Just Answers. Were not credited for our work until you rate our answers positively. After you rate our answers positively the question does not close. You can come back and ask follow up questions for no additional charge.
Thank you
Customer: replied 1 year ago.
Kelly ],
I have installed the new control board and run the test outlined in the service data sheet. Just ran the compete cycle but still no heat.
Please advise.
Paul.
Customer: replied 1 year ago.
Hi Kelly,
Any answer for me>
Paul
Expert:  Appliance Medic replied 1 year ago.
The last possible option is a broken wire. Ohm each wire out.
We work on the honor system here at Just Answers. Were not credited for our work until you rate our answers positively. After you rate our answers positively the question does not close. You can come back and ask follow up questions for no additional charge.
Thank you
Customer: replied 1 year ago.
Hi Kelly,
I'm just back from a trip and have checked the wiring and everything seems good.
What I did notice was when I tried to run the test cycle all the lights went out and nothing happened, any ideas?
Paul
Expert:  Appliance Medic replied 1 year ago.
Strange. You have replaced every single part for the heat cycle? Are you getting voltage to the element? Where are we loosing power at? You need a volt meter to figure that out. We work on the honor system here at Just Answers. Were not credited for our work until you rate our answers positively. After you rate our answers positively the question does not close. You can come back and ask follow up questions for no additional charge. Thank you

Related Appliance Questions