How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Bryan Your Own Question
Bryan, Home Appliance Technician
Category: Appliance
Satisfied Customers: 12156
Experience:  15 yrs. experience as a certified appliance technician.
Type Your Appliance Question Here...
Bryan is online now
A new question is answered every 9 seconds

I have a GE refrigerator (PFSF5PJYA BB) that stopped working.

This answer was rated:

I have a GE refrigerator (PFSF5PJYA BB) that stopped working. The front panel display flashed "00 00" then a scrolling "0" and this cycle would endlessly repeat. The lights were on inside the fridge. I attempted to "reset" the diagnostic mode by holding down all four temperature adjustment buttons, and tried unplugging the fridge for several minutes and plugging it back in. I read online that the problem was most likely the main control board. I found one locally, model WR55X10956, which I was told was the new model for the existing one on my fridge, a WR55X10774 which is evidently obsolete. I installed the new board, and the "00 00" series was still on the display, but after a few minutes it went away. The fan started, but the compressor is still not engaging. My question is: is there some sort of modification to the wiring that must be done considering that this is a different model circuit board from the original? Or is there something else going on? I have a little electronics training and have a multi-meter.
Hello, My name isXXXXX will be helping you today. Give me a few minutes to pull up your model. thanks .Be right back. okay so the compressor is the only thing not working ? all the fans and lights are ? the readout is working or not ? do you have a volt meter ?
Customer: replied 3 years ago.

Hi Bryan, yes, it is just the compressor. The fan, the lights and the front display are all working. And yes, I have a volt meter too.

okay this refrigerator has a 220 compressor, it has an inverter the converts 110 to 220 ,unplug the converter(next to the compressor) and test for 110 getting to it. if its getting 110 or 120 volts then the inverter has failed and needs to be replaced unfortunately. if you need the inverter heres a link to order it inverter
Customer: replied 3 years ago.

There are two connection, a single wire and a multi-wire connection, which color wire should have 110v?

Customer: replied 3 years ago.

Thanks, XXXXX XXXXX reading at about 110v. So this means the inverter is toast? Is this common for both the main control board and inverter to go out simultaneously?

yes actually. probably the converter went first and killed the board. its not uncommon. replace the inverter. its the only thing between the board and the compressor, everything else is running so that's all that's left. thanks and please remember to rate me 3 or above before signing off so I get credit for assisting you. Good job ! Bryan
Bryan and 3 other Appliance Specialists are ready to help you
Customer: replied 3 years ago.

The new inverter arrived last night. I installed it, plugged the refrigerator and it cycled through the diagnostic mode in about 20-30 minutes. However, this time after completing the diagnostic mode, neither the compressor fan nor the compressor engaged. The lights and inside fans come on when I open the doors and the front display panel and water dispenser work.

Any other ideas?


can you test for 220 volts coming out of the inverter ? unplug the connector at the compressor and test that ?
Customer: replied 3 years ago.

There are 3 wires (blue, blk, brwn). I assume the power and common are the blue and black, but I tested all possible combinations of the three and never got more 3 or 4 volts.

Wow okay but theres 120 going into it ?
Customer: replied 3 years ago.

No, now it doesn't! I'm getting ~2 volts on the orange and brown input.


Oh man, what the heck, you were getting 120 the other day correct ?
Customer: replied 3 years ago.

Yes, when I checked it the other day I was getting around ~110 v, but now that I check it again after installing the new inverter, I'm getting this low voltage.


I don't get that ? mmmm. are the fans running ?
Customer: replied 3 years ago.

Yes, they are now. When I installed the new inverter last night, only the inside fans would come on when I opened the doors. But this morning since I started messing with it, the compressor fan started up too.

well the main control board sends the power to the inverter and I'm not sure whats going on and why theres no power to the inverter now , The only thing I can say at this point is replace the main control board and see if it runs, heres a link to where you can get it and they have a full money back guaranty even if you installed it and it didn't work so I would try that . I just cant see anything else. heres the link.

Related Appliance Questions