How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Whrlp Master Tech Your Own Question
Whrlp Master Tech
Whrlp Master Tech, Whirlpool Master Technician
Category: Appliance
Satisfied Customers: 9051
Experience:  30 years Appliance Field 15 yr with Whirlpool Corp. 9 yrs Whirlpool Technical Assistance Line
Type Your Appliance Question Here...
Whrlp Master Tech is online now
A new question is answered every 9 seconds

I actually have two Maytag M7Y15F2A-A window AC units. Have been problem free for several

This answer was rated:

I actually have two Maytag M7Y15F2A-A window AC units. Have been problem free for several years but both units are not working now failing on back to back days.
Unit starts fine and all digital lights work and controls all function. within a few minutes the digital panel goes blank but unit keeps running. a few minutes later the airflow drops and than the unit shuts down. plug can become extremely hot.
cleaned the filter and front area but no improvement. Find it very hard to believe both units would fail on almost the same day. separate rooms but not sure if same circuit downstairs

Hello from JA
My name is Woody.
I will be glad to assist you today.
I have been servicing ALL Major Brands of Appliances for 32 Years,
and have over 100,000 in home repairs under my belt.

When they drop out ,can you test the voltage to the unit at the outlet ,since you say the outlet is getting hot?

I have to suspect an electrical issue .

Customer: replied 3 years ago.

Okay woody,
I'm fairly handy but electrical work is not one of my areas of expertise.
I'm traveling for work for a few days but I will check the outlets
When I return. Both are large units and have worked fine
With no electrical issue for over five years using those outlets.
I'll check to see if those are 15 amp or 20 amp lines.
Pretty sure they are 15 but few items on those circuits
I ran the ac off a separate circuit last night
And it ran fine for 10 minutes and than the digital display went
Blank. The unit kept running but no controls worked so I had to unplug it to turn it off. The plug was warm but not hot. I know these units
Are hard to find parts for. I'm hoping I don't need new circuit boards.
Is that something I could still get and could I install it if electrical issue
Is ruled out?

I have looked at four differant parts dealers and I only see one that shows any parts at all and they are NLA (No longer available)

Can you estimate how old the units are ?

Customer: replied 3 years ago.

Hey Woody,
My wife and I believe we got them 6 years ago but possibly just under 7.
I kept them in great condition and they have seen only a few months of use each summer since we live in New Hampshire. I'm hoping you are correct on the outlet being the issue since the units appear to have a lot of use left in them. I'll let you know what I find on the electrical outlet in a few days
No problem Eric good luck

Eric just keeping the question open till later .


Customer: replied 3 years ago.
Okay thanks
May have to wait until after holiday to get electrical issue checked first
Oh that fine Eric the question times out if not action on it I was just keeping it open
Customer: replied 3 years ago.
Oh okay
How often should I check back with you to make sure it doesn't close out?
I fly home tonight and hope to book an electrician for next Monday or Tuesday. I'm hoping its a simple breaker replacement and an easy fix
Of course we have high heat forecasted for the next 4 days

You do not have to do anything I will take care of it on my end , you just have a safe trip!

Customer: replied 3 years ago.

Hey Woody,
Hope you had a great holiday weekend. I have good news and bad.
Good for you and kind of bad for me. It looks like you were right about the two outlets running my Large window units. I bought two new units for other sections of my house and tried the units again that had been malfunctioning. Since the house had additional cooling units, the Maytags
We're running on the "energy saver" mode and at a higher temp setting.
They have worked perfectly for 48 hours with outside temps in the 90's and very humid. I'm going to have to have the outlets repaired and breakers replaced but I'm happy to report the Maytags were apparently malfunctioning due to an insufficient electrical supply. Woody thank you for your quick assistance and keen ability to figure out the problem.
Eric H.

Eric It was my pleasure to assist you .

Whrlp Master Tech and 3 other Appliance Specialists are ready to help you

Related Appliance Questions