How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Bryan Your Own Question
Bryan, Home Appliance Technician
Category: Appliance
Satisfied Customers: 12156
Experience:  15 yrs. experience as a certified appliance technician.
Type Your Appliance Question Here...
Bryan is online now
A new question is answered every 9 seconds

MSD2756DE is not holding temperature, fan running all the

This answer was rated:

MSD2756DE is not holding temperature, fan running all the time.

Hello, Thank you for using this service, I will be helping you with your problem today

Good morning. Can you open the freezer and look on the back wall in tell me if there is any frost on it?

Customer: replied 3 years ago.

Yes, frost is present

Okay this is the most common problem on this refrigerator, these have an adaptive defrost board in them, they are electronic, Defrost Control Board 61005988 Alternate Product ViewThey had two lead design these because of failure. Now these can be a little difficult to install so I am going to see if I can find the video that shows you how to do it. In the meantime to get this running correctly until you can order the part. Remove the back panel that has the frost on it and defrost it with a hair dryer, put the panel back In and this will run correctly for about three weeks plenty of time to receive the part, here is the link to order the part . I will be back shortly with the video. thanks , Bryan

Bryan and 2 other Appliance Specialists are ready to help you
here is a great video on how to replace the control. click this blue link. Video thank you and have a great weekend, Bryan
Customer: replied 3 years ago.

Switch in. Video was perfect. Defrosted front of panel and plugged back in. Compressor and fan rrunning. Realized I needed to defrost accumulator coil completely. Used hair dryer. 100 percent ice free. Replugged in. Lights on but compressor and fan not running. Is there a hi temp sensor that may have heated up, hence I need to wait before compressor starts....

this may be in a defrost cycle wait a little while and see if it comes back on. could be 20 minutes but should be faster.

Related Appliance Questions