How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Tyler Z. Your Own Question
Tyler Z.
Tyler Z., Appliance Doc
Category: Appliance
Satisfied Customers: 73466
Experience:  9+ years being an appliance technician with factory training.
Type Your Appliance Question Here...
Tyler Z. is online now
A new question is answered every 9 seconds

Model #JTP90SM1SS Ge Built in oven w

This answer was rated:

Model #JTP90SM1SS Ge Built in oven w/microwave -- Oven display seems to function normally -   set oven to 300  ... display switches to (i assume what is ) current temp  100 degrees but ... nothing after that


Hello, and thank you for using this service. I'll be helping you with your problem today.

So there are 3 parts that can cause this problem in addition to the control board. You'll need to test the continuity through each of these 3 parts with the wires disconnected to them, and if any of them don't have continuity, then the device needs to be replaced. Below is a diagram and I've circled parts 157, 158, and 159 that you'd need to check. Unfortunately it will require un-installing the entire unit and removing the back panel to test continuity through the parts.
Now if all 3 of these parts have continuity, you'd need to replace the control board for the oven.

Please remember to rate my service before you leave. If you have any other questions, please ask me – I’ll be happy to respond. You can continue asking follow-up questions until you have all the information you need even after rating my service. Thank you!

Customer: replied 3 years ago.

looks like a dryer schematic ... i need help w/ an oven .......


Model #JTP90SM1SS Ge Built in oven w/microwave -- Oven display seems to function normally - set oven to 300 ... display switches to (i assume what is ) current temp 100 degrees but ... nothing after that

I'm sorry, I uploaded the wrong picture. I do apologize. Below is the picture I meant to upload.


Also, it doesn't matter if the display appears to function normally or not. The display also is the part that sends power to the elements so if these parts all check good, the display board would still need to be replaced


Customer: replied 3 years ago.

ooops ... this thing have (hidden) bake element that could be bad?

Correct is does. But the bake element would only be a possibility if the broil still works. So try broil first. If neither bake or broil heat at all, the elements are not your issue.

Tyler Z. and other Appliance Specialists are ready to help you
Customer: replied 3 years ago.

I don't seem to have part # 159

The image was looked up using your model number, so it should definitely be there, but I couldn't say for certain without being there to look at your oven. It'll be mounted to the top above the microwave but below the microwave behind the vent that separates the two appliances.

Customer: replied 3 years ago.

the schematic I found inside is publication number 31 dash 14562... It seems to be correct... I found and tested 3 fuses

OK, so if they all test good and it's not heating, make sure you have 240 volts to the oven. if so and it won't bake or broil, then you need to replace the main oven control board.

Customer: replied 3 years ago.

Thanks ... I tried to send you a pic but the interface didn't work with my android Google Chrome browser if (Phone). is there a way to text or email you pictures for future reference?

Unfortunately not. We've been having trouble with the picture upload function for a week or so no and I know the engineers are on it, but sometimes it's working and other times it just won't work. But you would need to use Firefox or Internet explorer to use the picture upload function for future reference. The site isn't compatible for Chrome as far as these chat functions are concerned.

Customer: replied 3 years ago.

JTP90SOM1SS is the model number I'm working on... I may have mistakenly given you Jay tee p 90 s m1ss ..... Do you have a part number for that control board please

The part number is WB27T10915.

Related Appliance Questions