How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Bryan Your Own Question
Bryan, Home Appliance Technician
Category: Appliance
Satisfied Customers: 12156
Experience:  15 yrs. experience as a certified appliance technician.
Type Your Appliance Question Here...
Bryan is online now
A new question is answered every 9 seconds

I have an old Amana refrigerator SRD522ve. A repairman replaced

This answer was rated:

I have an old Amana refrigerator SRD522ve. A repairman replaced the broken icemaker and it works okay now but when i push a cup against the bar nothing happens as if it gets no power or something.
Is there anything i can do myself?
I am living in the Netherlands and when I let the repair guy come again it costs 120 dollars again....

Maybe he forgot to connect a simple wire or something?

Hello, Thank you for using this service, I will be helping you with your problem today

do you still get water through the door ?

Customer: replied 3 years ago.

Yes I do. The water is doing fine


okay. do you hear anything when you press for ice at all ?

Customer: replied 3 years ago.

No, no sound

okay you need to check the ice auger motor for 120 volts with a volt meter. do you have one ?
Customer: replied 3 years ago.

Yes, found one.

Where do i have to measure?


Customer: replied 3 years ago.

forgot to tell but before the repair guy came this part worked well.



okay its in the back behind the ice bucket number 0461 on this diagram . make sure you press the light switch in as if the door was shut and then press for ice. you should get 120 volts.
Customer: replied 3 years ago.

ok I'm there now .

haven't measured yet because there are some lose threads

one yellow that is coming from the light (or further down.

That one is not connected.

three threads are running from the motor 0461. to the black thing 1411

One black is running to a connecter so i suppose that one is okay. then a black.that is running to a black thing 1411 in the picture. on that spot there are two connectors but only this one is occupied. (maybe that yellow thread has to put on there?

there is a orange one. That is also running to 1411 but that one is broke. the orange one is then going further from that connector in the direction of the light.

I hope you understand my crooky english (sorry for that)


holly cow. hmmm, it looks like someone may have done some rewiring in that. Or broke some wiring off. I don't have a wiring diagram for that either, does it look like the orange wire broke off the part where I put an arrow ? graphic
Customer: replied 3 years ago.

yes you are right thats where the orange one is broke (sorry thread is an English word I guess, but i ment wire ofcourse.

But if it is still not working, shall i try to connect the yellow wire to the connector on 1411 that is still free (probably i connect the yellow to the black one then.


to tell you the truth I'm not sure where the yellow one may go but I'd be careful, it may be for some other use , where do you think it would reach ? is there an empty connector there it may go to ? I cant see by the picture
Customer: replied 3 years ago.

yes where the black one ends on 1411 there is a slot. That is the only one.

I tried to point it out for you with an green arrow but when i press reply to expert i am denied on the server.


Anyway, i unscrewed the light because the yellow wire is running to there and behind is , I can see a plastic connector for the yellow and orange wires together and both are disappearing to the side then. So probably the orange and yellow are a pair?. And then it make sense to try to connect the yellow wire also to that 1411 thing?

okay so the yellow goes to the light ? and the light works without it connected? 1411 is the capcitor

Customer: replied 3 years ago.

not really to the light but to a gap behind the light where they made some space for a few plastic connectors.


the light works.

I'll try to make a picture but maybe it is not possible to send that (access denied to the server.... )

yeah their having site problems, sorry. try hooking up the orange one first and see if it works if not then try the yellow
Customer: replied 3 years ago.

okay i'll try that. but have to buy a connector for the broken one first.

I'll do that tomorrow (it is midnight over here in the netherlands now..


Thanks very much for your help.



your welcome, let me know, thanks Bryan
Customer: replied 3 years ago.

Hi Brian,



I ,(well you) managed.

I first connected the orange wire and it worked but only when the switch in front was put to crushed and not when it was switched to cubes.

So I connected the yellow wire too and now everything is working fine.


Once again thanks a lot





thats fantastic. I hope at least I was some help. Please remember to rate me 3 or above so I get credit for assisting you, thanks and good job! Bryan
Bryan and 4 other Appliance Specialists are ready to help you