How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Appliance Guru Your Own Question
Appliance Guru
Appliance Guru, Owner and Technician
Category: Appliance
Satisfied Customers: 13429
Experience:  Over 15 yrs. experience with 10,000+ in home repairs.
Type Your Appliance Question Here...
Appliance Guru is online now
A new question is answered every 9 seconds

kssc42fms always on over temp reset mode

This answer was rated:

kssc42fms always on over temp reset mode
Thanks for using this service. Please be logged in to rate my assistance when we are done. Rating 3-5 is good, but 1-2 is bad so talk with me first.

What is the unit displaying?
Customer: replied 3 years ago.

Is the compressor and both freezer and fan by the compressor running?
Customer: replied 3 years ago.

Yes, but fan or compressor (cant identify which) gets intermittently noisy for hours at a time. The digital temp displays also seem to be innacurate, and over temp alert is always on.

Does the temp seem ok in both sides?
Customer: replied 3 years ago.

Yes. Ice is hollow, but that may be another issue, or connected. Not sure.

Well that unit is an inverter unit so there is a lot that can cause this issue. Take the light cover off and remove the screws so the console comes down. You will see a small board with a ribbon cable attached tell me when you see it.
Customer: replied 3 years ago.

Ok, I got the panel down.



Unplug the cable going to the board and plug it back in
Customer: replied 3 years ago.



Customer: replied 3 years ago.

Over temp light still on


Is it flashing and beeping
Customer: replied 3 years ago.

Rapid flashing only.

Ok either the inverter board is bad or the control is bad. I believe the temp control is bad. Is the display dim in one spot?
Customer: replied 3 years ago.

Display is all good. Not dim at all.


Ok let me grab the service manual so you can run diagnostics
Customer: replied 3 years ago.



See if it will go into diagnostics

To enter the diagnostics mode:
• Press and hold the Water Filter Reset
keypad, and then immediately press and
hold the Power keypad. Continue to press
both keypads for 3 seconds, or until you
hear a beep
Customer: replied 3 years ago.

ok done

To advance to the next step in the sequence,
press and hold the Water Filter
Reset key for 2 seconds, or until you hear
a beep. The Diagnostics Chart on the next
page shows the step number and the component
being tested in each step.

01 FreezerThermistor
02 Refrigerator Thermistor
03 Evaporator fan
04 COndenser Fan
05 Compressor
06 Air door
07 Defrost Heater/bimetal

You should see the test number in the left and the result in the right window. You can advance to the next test by holding the water reset key for 2 secs until you hear a beep and see the next number test come up. Let me know all the result numbers in the right window for each test. The result number will be 01 through 03 for the results.
Customer: replied 3 years ago.

Results are :


1 - 1

2 - 1

3 - 2

4 - 1

5 - 2

6 - 1

7 - 1

Ok that is showing an error with the evaporator fan motor. The fan is showing it is not running at the correct speed. The fan may be bad, this is likely the whole issue and the reason it is going over temp. When in diagnostics at the evaporator check....check the voltage from P7-9 pin to P7-10 pin for 5-17 volts DC, can check it right off the electronic main control board plug. If you have it there replace the fan. If not replace the control. That would cause all the issues you are having. Also check to make sure the fan is not jammed.

Customer: replied 3 years ago.

Do you have part numbers for fan and control ?


Also are you referring to the main control board being bad ?



Yes the main control not the inverter board. If you want remove the back panel in the freezer to get at the fan you can check between the White and Yellow wires when in diagnostic at the evaporator test for 5-17v volts DC and if you want to test the motor. Unplug it and check the outer pins for 1400-1700 ohms. Now they had a lot of issues with the main control board and they do not sell them new anymore. You would have to send it in for a rebuild. It sucks but that is all you can do right now. Note this is for model 00....if your model has nothing after the last letter then these are the correct parts. All I ask is that you rate my assistance thanks! tips are greatly appreciated as well but not required.

Here is a link to the board CLICK HERE

Here is a link to the fan motor
Customer: replied 3 years ago.

Sorry to bug on this. Mine is the 03 model, which I believe is the newer version. Can I bother you to get me part #'s for this version. Thanks !

Yes no problem...they may be the same let me just double check
Ok fan is the same, board is not....still the board is NLA...but there is a place you can get a reman board from. Here is a link to your board that you can order if it is the issue. The board may likely be the issue as the fans do not normally go bad...but test it to make sure.

Customer: replied 3 years ago.

Doesn't the board supersede to part # XXXXX ?


Yes it does the link I provided is the remanufactured board that covers that one and a few others.
Customer: replied 3 years ago.

Would a loud fan type groaning noise, coming intermittently from the unit, lean towards one part or the other being bad ?



Yes the fan could be bad you would just have to take it apart to test it. The fans do go bad on that unit as well. So if the bearings are bad on the fan that could be the reason it is makign noise and not running up to speed.
Appliance Guru and other Appliance Specialists are ready to help you
Customer: replied 3 years ago.

I have replaced the main board, and evap fan on this unit. It was good for 5 days then went back into over temp alert, and shows the freezer at 42 degrees (which it is not).

The display temp control board could be bad or you may have a bad thermister. Hard to say since it worked for 5 days, very odd issue.

Related Appliance Questions