How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Chas Your Own Question
Chas, Home Appliance Technician
Category: Appliance
Satisfied Customers: 16417
Experience:  Maytag, Whirlpool, GE & Kenmore Factory Trained Service Tech
Type Your Appliance Question Here...
Chas is online now
A new question is answered every 9 seconds

I have a ten year old Kenmore Energy Star dehumidifier that

Customer Question

I have a ten year old Kenmore Energy Star dehumidifier that no more "dehumidifies', although the motor works (bucket stays empty). What to do ? Thanks.
Submitted: 3 years ago.
Category: Appliance
Expert:  Chas replied 3 years ago.
Hello my name is Chas. I look forward to assisting you today with your question and providing the best answer possible. First, we will need to troubleshoot your issue as there is most likely not a quick fix. Please do not to rate until our conversation is finished, you can reply to me any time even after rating by clicking on reply to expert. Please also note, some issues require parts to be replaced which is out of my control (though I sincerely wish it was).

Thank you for using for your appliance questions, Myself and all the other experts are anxious to help you with your problem today. If you will please explain your problem and the model and serial number we can get started...


Also would like to know how old the unit is please?





Customer: replied 3 years ago.

Optional Information:
Brand: Kenmore Energy Star dehumidifier
What have you tried so far?: Nothing to do ? Motor works but nothing in the bucket.


Probably ten years old.


Kenmore Energy Star -no other model info available.



Expert:  Chas replied 3 years ago.
On a 10 year old model, then this was made by Frigidaire for Kenmore, More likely than not the condensor has rusted out on the unit allowing the freon to leak out, cost to repair this would be over $200 which is more than the replacement for a new unit, Frigidaire units were known for this problem and usually happens around year 7.. However your model seem to last longer...

All I ask of you is to please rate me with one of the top 3 ratings. If there is anything else I can help you with today just let me know. You can continue asking questions for as long as you like even after you rate me. Click the continue conversation link if you would like to continue this conversation. If you are done and rate a 1 or 2 star please consider using the "continue conversation" link and telling me what more I can do or what more you would have liked that was within my power so that I possibly give you that information or help me improve my customer satisfaction rating. . .

Bonuses are welcome if I have helped you a lot, however they are not mandatory

Related Appliance Questions