How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Bryan Your Own Question
Bryan, Home Appliance Technician
Category: Appliance
Satisfied Customers: 12156
Experience:  15 yrs. experience as a certified appliance technician.
Type Your Appliance Question Here...
Bryan is online now
A new question is answered every 9 seconds

Our upper oven does not heat to the proper temp. It is 100

This answer was rated:

Our upper oven does not heat to the proper temp. It is 100 and some degrees low. Is this a complex repair?

Hello, Thank you for using this service, I will be helping you with your problem today

do you have the model number ?

Customer: replied 3 years ago.

X301X or 302 or 272

okay, is this gas or electric ?I'm having a hard time finding the info on this. is this your control panel ?
Customer: replied 3 years ago.

Yes, that's my control panel. It is about 12 years old and is a "wall oven".

that is there is no range on top. It has convection included. I can't find the model number on the oven but the quick cooking guide has those three model numbers on it.

okay can you tell if the bottom element in the top oven is getting red hot during preheat ?
Customer: replied 3 years ago.

I set bake at 350 and pushed start. It claims to have reached 325 so far and the bottom element is a dark rose color. I don't know what red hot looks like! It is heating. It is now claiming 350 and it looks heated but as I say rosey if that helps.

okay are you using a thermometer to tell the temp is off ? did you put one in the oven to see the temp ?
Customer: replied 3 years ago.

I looked in the oven a couple of minutes later and the bottom element was black, still read 350 and was black minutes later. YEs we have tested it with a thermometer and I think it was 125 off or more.


okay, since the element is working this means the oven control board is the issue. the relay on the board is not holding in or the oven sensor is bad. you will need to call Thermadore out to repair this. the parts are showing not available in my database. this doesn't mean they are unavailable through Thermadore however. I wish I could help more, sorry. thanks and best wishes, Bryan
Bryan and 5 other Appliance Specialists are ready to help you

Related Appliance Questions