How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Tyler Z. Your Own Question
Tyler Z.
Tyler Z., Appliance Doc
Category: Appliance
Satisfied Customers: 73368
Experience:  9+ years being an appliance technician with factory training.
Type Your Appliance Question Here...
Tyler Z. is online now
A new question is answered every 9 seconds

Hi, I have a Kenmore Dishwasher model 665 stock# XXXXX It

This answer was rated:

Hi, I have a Kenmore Dishwasher model 665 stock# XXXXX It worked great up until last week but now it is not working properly. When I press "normal" and then "start" it first pulls in the water and then begins what sounds like a washing noise for about 30 seconds to 1 minute. During that time the "sensing" light is lit up. Then, (when I assume it's supposed to start heating) it shuts off and the "high temp scrub" light continues blinking red with the water still in the dishwasher. Sometimes it will cycle back on by itself and then shut back off after about 30 seconds, repeating the process. I don't know anything about dishwashers but I am a computer technician and my guess is a bad heater. Can you tell me what you would suspect and if there is any other troubleshooting I can do to pinpoint the bad part? Thanks for whatever help you can provide.
Hello, and thank you for using this service. I'll be helping you with your problem today.

This means that your control board is just going bad unfortunately, this is NOT a heater issue. Below is a link to the control board you'll need to order.


Customer: replied 5 years ago.
Thank you for your answer! Are you pretty sure the control board is the problem? These boards are pretty pricey (compared to the entire dishwasher) but I found a remanufactured one for $60 which is reasonable if it fixes the problem. If you are pretty certain I will order one today and should receive it between June 6th and 10th and if all goes well I will accept your answer and pay at that time.
ok well good luck, and based on what you're saying, it's the only thing that can cause this problem.

Tyler Z. and 3 other Appliance Specialists are ready to help you
Customer: replied 5 years ago.



I just wanted to let you know that I received my Control Board today, installed it, and all is working great now! I will go ahead now and accept your answer and pay you. Thanks again for your help!

awesome, glad it's all working again. You have a great weekend.

Related Appliance Questions