How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Appliance Man Your Own Question
Appliance Man
Appliance Man, Home Appliance Technician
Category: Appliance
Satisfied Customers: 9896
Experience:  Appliance tech 4 years
13888241
Type Your Appliance Question Here...
Appliance Man is online now
A new question is answered every 9 seconds

Frigidaire Affinity washer ATF7000e The spin cycle does

Customer Question

Frigidaire Affinity washer ATF7000e

The spin cycle does not want to kick on....the machine will wash, the drum will spin during the wash cycle, but won't during the spin cycle.

I cleaned out the drain hoses both inside the machine and the one leading to the laundry tub....reconnected everything but still no spin...any suggestions? could it be the pump?

regards,

Ralph
Submitted: 6 years ago.
Category: Appliance
Expert:  Appliance Man replied 6 years ago.
Hello. Thank you for choosing Just Answer. I will be helping you with your question today.Yes or something might be inside the pump jamming it.
Customer: replied 6 years ago.
I have the pump in my hand right now and when i stick my finger in the opening, the pump blades spin but not freely probably because of the magnets?

does this mean the pump is okay?
Expert:  Appliance Man replied 6 years ago.
Ok hook the electrical connector back up to the pump. Select drain spin and see if the pump kicks on.
Customer: replied 6 years ago.
ok will give it a try and be back in a few minutes
Expert:  Appliance Man replied 6 years ago.
ok let me know.
Customer: replied 6 years ago.
okay all reconnected but still no spin cycle...

sounds like it's not the pump...any other ideas?
Expert:  Appliance Man replied 6 years ago.
Did you remove and clean the change catch in the hose that goes from the tub to the pump?
Customer: replied 6 years ago.
yes, i found two hair pins and about 8 coins...cleaned it all out very thoroughly including the pump and both hoses
Expert:  Appliance Man replied 6 years ago.
If it still isnt pumping then replace the pump.
Customer: replied 6 years ago.
so even though the pump is working when i reconnected it with just the electrical connection, when i reconnected all the hoses and turn on the water, there is the possibility that the pump is not pumping?
Expert:  Appliance Man replied 6 years ago.
It has to he the pump. If all the hoses are clear and the pump is getting power and running it has to be the pump not pushing the water out.
Customer: replied 6 years ago.
ok will try
Expert:  Appliance Man replied 6 years ago.
ok.
Customer: replied 6 years ago.
i ordered the part two days ago...got it installed just now and did a test load on permanent press (shortest cycle 34 minutes) ....when the timer was at just under 1o minutes left, it seemd that the time was messed up....it seemed to lose a minute quicker than it should have....then when there was 6 minutes left in the cycle it started to spin but then the timer went to zero...it's like it started to spin (the initial short spins sided to side ) but it never even got to the final big spin where it spins super fast....after that permanent press cycle, i tried just the spin cycle, which was 12 minutes. As soon as i hit the start button, the machine turned on and the timer went immediately to 11 minutes (where did the 1 minute go? it just disappeared) ...then it seemed to be draining the water and then it started the small spins side to side but as soon as the timer got to 6 minutes the time went to 0 and turned off. The rest of the 6 minutes never happened and it never spun.

any suggestions?
Customer: replied 6 years ago.
i just tried the spin cycle again...it starts at 12 minutes, the machine comes on and it sounds like it starts to drain the water....but i lose a minute quicker than it should go....I know this because i timed it....then i keep losing time as the minutes seem to go by faster than they shoud...when it reaches 6 minutes left the drum spins side to side but doesn't spin any faster then the timer goes from 6 minutes to 0 and the machine shuts off and the interior drum light turns on...not sure if i am giving you all the info you need...please let me know what you think as it seems that the new drain pump really didn't do anything