How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask servicegeek Your Own Question
servicegeek
servicegeek, Home Appliance Technician
Category: Appliance
Satisfied Customers: 720
Experience:  I have been a service tech for over 10 years at a leading service company.
47503688
Type Your Appliance Question Here...
servicegeek is online now
A new question is answered every 9 seconds

Sub-Zero 630 Refrigerator/Freezer is leaking in the front at

Resolved Question:

Sub-Zero 630 Refrigerator/Freezer is leaking in the front at the bottom. Water coming from the front creating a puddle. It's worse when it's warmer or more humid.

10 years old.

Thanks in advance.
Submitted: 6 years ago.
Category: Appliance
Expert:  servicegeek replied 6 years ago.
Hey i will try to help you. You need to remove the kickpanel at the bottom and see if the water valve is leaking or the supply line. The other thing you need to check is to open the unit up and look in the bottom of both sides and see if you see and ice or water sitting in the floor . If you do have ice buildup or water this could mean you have a clogged defrost drain. Hope this helps and please remember to click accept.
servicegeek and other Appliance Specialists are ready to help you
Customer: replied 6 years ago.
Thanks.
Seems to be a drip from the bottom of the unit. Supply line and valve look ok.

You mention opening up the unit.Do i have to pull the unit out of the wall? How do i start?

Thanks
Customer: replied 6 years ago.
Thanks.
Seems to be a drip from the bottom of the unit. Supply line and valve look ok.

Ok, opened up the unit. puddle of water on the bottom , 1/8 inch, and thats the source.




Thanks
Customer: replied 6 years ago.
Got it. the drain tube in the back was clogged.
Thanks

Related Appliance Questions