How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Tyler Z. Your Own Question
Tyler Z.
Tyler Z., Appliance Doc
Category: Appliance
Satisfied Customers: 78804
Experience:  9+ years being an appliance technician with factory training.
13574879
Type Your Appliance Question Here...
Tyler Z. is online now
A new question is answered every 9 seconds

hi i set tep.to recomend temp lights are working fan is working

Customer Question

hi i set tep.to recomend temp lights are working fan is working but ref and freeze stop working all the sudden what could be the possible reason and how can i fix it without going through of spending lot of money i will really appriciate your help my ref is whirlpool i bought this in 2002
Submitted: 7 years ago.
Category: Appliance
Expert:  Tyler Z. replied 7 years ago.
do you have a model number so that I can better assist you? Is there any display or anything?
Customer: replied 7 years ago.
hi model number is-gr2shkxkso2 and series is em3428151
Expert:  Tyler Z. replied 7 years ago.
ok so pull the refrigerator out. Remove the back bottom cover and unplug the unit. There is a small plastic box attached to the side of the compressor. This is called your overload relay device and has several wires going to it. Pull this part off the compressor and shake it. If it rattles you need to remove and replce it.
Customer: replied 7 years ago.
i think my relay is ok because i checked it personally it doesnt make any noise it also doesn,t have any burn or any smoke sign and also dont see anybubble on that rely seal i mean that sealer jell
Expert:  Tyler Z. replied 7 years ago.
ok well if your relay is good then your compressor itself is bad. The freezer fan running means the unit knows that it needs to cool so if it's not cooling then your compressor isn't running and that's either an issue with your compressor or the relay.