How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask william Your Own Question
william, Home Appliance Technician
Category: Appliance
Satisfied Customers: 3034
Experience:  Major Home Appliance Technician Specialist Whirpool Certificate
Type Your Appliance Question Here...
william is online now
A new question is answered every 9 seconds

I have a Hitachi MMP-401 GPS. When I turned my GPS on yesterday

Customer Question

I have a Hitachi MMP-401 GPS. When I turned my GPS on yesterday I think that my battery was very low. At that stage I got the first screen that showed Navigation & Entertainment. The top left of screen has the words Top Menu. I recharged the GPS and as when the battery was low if I click on Navigation I got an egg timer that does not change. If I tap the screen the egg timer rotates. The navigation does not open. The only way to remove it is to turn off the GPS. The entertainment function is working properly. Can you please advise what action to take to remove the egg timer and get the GPS working.
Submitted: 7 years ago.
Category: Appliance
Expert:  william replied 7 years ago.
so your problem is just with this egg timer that wont go away right?
Customer: replied 7 years ago.
No the Navigation facility will not open at all. The egg timer is what activates when you tap on the navigate feature.
Expert:  william replied 7 years ago.
did you just but this?
Customer: replied 7 years ago.
No it is about 2 years old. It has been working perfectly right up to last Friday when I turned it off, when I turned it on the egg timer was there.
Expert:  william replied 7 years ago.

i reviewed your gps manuel and couldnt find anywhere about a egg timer it was just tap/go and you should have been there make sure battery is fully charged maybe its searching for a signal try plugging in your car charger to it leave it hooked up and see what happens if that dont work i would take it in to get serviced or look into another one hope this helps



If you have found this info helpful then please press GREEN ACCEPT button, this is how EXPERTS are paid for helping you.
I work harder so you won't have to!

Related Appliance Questions