How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Tom Goellner Your Own Question
Tom Goellner
Tom Goellner, Home Appliance Technician
Category: Appliance
Satisfied Customers: 1604
Experience:  32 yrs. experience servicing major appliances and HVAC equipment.
6636336
Type Your Appliance Question Here...
Tom Goellner is online now
A new question is answered every 9 seconds

troubleshoot a GE JES1344SK02 m-wave.

This answer was rated:

have a GE JES1344SK02 m-wave. everything seems ok, but no heat. I read about 15 ohms between the magnatron contacts. The HV cap. seems to read oddly - the resistance starts at about 1M ohm and settles at about 10M ohm, but a diagram on the case indicates there is an internal 10M ohm bleeder; I''d expect the resistance to start at zero ohms and climb from there. I''ve never tried to troubleshoot a m-wave oven before - is this a normal reading for this type of capacitor? I found the HV diode between the cap and gnd, it reads 22M ohm, biased. If these readings are normal, what else do I need to look at?
HelloCustomer First verify that you have 120 volts to the primary side of the high voltage side of the transformer. If yes then you really need a clamp on ampmeter and measure the current draw on both wires going to the magnetron - - should be about 11 or 12 amps. You can't really check the capacitor correctly with a digital ohmmeter but it sounds like it and the diode are ok.
Tom Goellner and 2 other Appliance Specialists are ready to help you
Customer: replied 8 years ago.
I'm fairly certain that I'll have 120v to the xfmr, because when I put the cap back in - i crossed the wires and it blew the line fuse when i started the oven! If not drawing 11-12 Amp - then the tube is probably bad? if it is drawing 11-12 Amp ... ?

YesCustomer/p>

Well you're right about proving there's power to the transformer and high voltage leaving transformer. Magnetrons can fail in different ways but a common fault is they will draw more current on one wire than the other which means the filament is shorting to the anode , I would bet that you have a defective magnetron. Thanks for using justanswer.