How JustAnswer Works:

  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.

Ask ITPeter Your Own Question

ITPeter, Engineer
Category: Android Devices
Satisfied Customers: 15427
Experience:  Electronic Engineer
Type Your Android Devices Question Here...
ITPeter is online now
A new question is answered every 9 seconds

I have an LG G Pro lite and Im trying to install pokemon go

Customer Question

I have an LG G Pro lite and Im trying to install pokemon go but it is saying that my device isnt compatible. Currently using 4.4.2 and pokemon's requirement is 4.4 - 6.0
Submitted: 2 months ago.
Category: Android Devices
Expert:  ITPeter replied 2 months ago.

Hi Renette,

Sorry to hear you are having this problem.

Your v4.4.2 may be carrier-specific.

Try downloading a different APK, e.g.

Let me know if that works?

Customer: replied 2 months ago.
ok, will try the link
Expert:  ITPeter replied 2 months ago.

Let me know how it goes or if you need anything else :)


Customer: replied 2 months ago.
I cant accept the phone call since i am outside US. BTW, already tried 29 and 0.31.0 but still the same issue. I was able to download the app, it worked on the first part, it asked for my date of birth but after selecting the account(i selected google play) it's giving me a black screen and app will restart with Niantic logo
Customer: replied 2 months ago.
Btw, went to APK mirror and saw two variants:
(###) ###-####(###) ###-#### you know what's the difference?
Expert:  ITPeter replied 2 months ago.
is the most recent release to fix a few minor bugs.
Expert:  ITPeter replied 2 months ago.

Hi, just checking in on your question, do you need any further assistance?

Related Android Devices Questions