How JustAnswer Works:

  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.

Ask Russell H. Your Own Question

Russell H.
Russell H., Service Tech
Category: Android Devices
Satisfied Customers: 9528
Experience:  8+ years of professional experience
13568747
Type Your Android Devices Question Here...
Russell H. is online now
A new question is answered every 9 seconds

When I open the emulator it opens the app but it gets stuck

Customer Question

When I open the emulator it opens the app but it gets stuck on the app loading screen, why is it doing this?
Submitted: 8 months ago.
Category: Android Devices
Customer: replied 8 months ago.
I changed my XMLResourcePath from a website to a local xml file, once I did this I cant get my app to open in the emulator, it just gets stuck in the loading screen, I can see messages in the android monitor coming in every few minutes while I wait, I have left it on loading for hours but it never opens.
Expert:  Russell H. replied 8 months ago.

Hi, thank you for contacting JustAnswer.com. My name is Russell. I will do my best to provide the right answer to your question.

Perhaps you wrote or added in the reference to the local XML file, incorrectly, so that the emulator cannot find the file.

Please give the reference to the local XML file to me, so that I can judge whether that might be the case.

Also the first few lines of the XML file might be what's wrong, too, if they are giving the app as emulated a bad direction.

I need to ask whether the app really did load and run, in the emulator, before you switched the XMLResourcePath ?

What messages come in every few minutes while you wait?

Customer: replied 8 months ago.
1. Yes the app ran fine before.
2. I get messages like this -
03-14 21:11:19.554 2353-2360/com.dmbteam.catalogapp W/art: Suspending all threads took: 9.529ms
03-14 21:12:53.049 2353-2379/com.dmbteam.catalogapp E/com.parse.ParsePushRouter: Ignoring PPNS push missing timestamp
3. The xml reference is this -
public static final String XMLResourcePath =
"catalog.xml";
The name of the xml file is catalog.xml
4. The beginning lines for my xml file are this5. I can see changes I have made to the app behind the loading icon.
Customer: replied 8 months ago.
Ill send 4 again because it didnt show up-
the beginning lines for me xml file is this
Customer: replied 8 months ago.
I have added 4 in an attachment
Expert:  Russell H. replied 8 months ago.

3. The xml reference is this -
public static final String XMLResourcePath =
"catalog.xml"

Please also state for me, the XML or other reference, in full and exactly, for the previous configuration where a website was referenced instead of a local xml file. Thanks.

Customer: replied 8 months ago.
I have attached the xml reference
Expert:  Russell H. replied 8 months ago.

I see that text file and the previous reference, thank you.

public static final String XMLResourcePath =
"catalog.xml"

is not sufficient for the catalog.xml to be found.

Try this, in place of "catalog.xml" :

"file://C:/xmlfiles/catalog.xml";

where

C:/xmlfiles/

is replaced by whatever path there is on your computer (it may be an Apple, so I'm hedging any specifics on this piece of advice) ...to the catalog.xml file.

Customer: replied 8 months ago.
This is the path to catalog.xml
[catalogApp] C:\Users\Fran\Desktop\ShoppingApp2\dmbteam_mobile_shop_v2.1\catalofApp\src\main\assets\catalog.xml
How should I write this on there
Expert:  Russell H. replied 8 months ago.

public static final String XMLResourcePath =
"file://c:/Users/Fran/Desktop/ShoppingApp2/dmbteam_mobile_shop_v2.1/catalofApp/src/main/assets/catalog.xml"

Customer: replied 8 months ago.
I made the changes but its still not loading, any thoughts? I have attached the path
Expert:  Russell H. replied 8 months ago.

Try leaving out

C:

and making the path begin

file:///Users

or try making the path begin

file://Users

(I doubt this, just airing it, not likely I don't think!)

Customer: replied 8 months ago.
its still not opening, are you sure thats the problem?
Expert:  Russell H. replied 8 months ago.

I'm not sure what the problem is, and I should (and I have) Opted Out.

Customer: replied 8 months ago.
its been more than 24 hours still no response

Related Android Devices Questions