How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Curtis B. Your Own Question
Curtis B.
Curtis B., Technician
Category: Agriculture and Farm Equipment
Satisfied Customers: 27485
Experience:  Technican turned service manager on multiple lines of equipment and rental equipment.
30244710
Type Your Agriculture and Farm Equipment Question Here...
Curtis B. is online now
A new question is answered every 9 seconds

I have a 2007 Gehl 6640E with the Deutz 2.4L engine, 1792

This answer was rated:

Hi, I have a 2007 Gehl 6640E with the Deutz 2.4L engine, 1792 hours- started last night went snowploughing ran like a top. Came home, plugged her in and went to my day job. Came home tried to start it, turning the key gets you a click- nothing else. Battery is new, and boosting with running pick up does nothing.
JA: What is the complete model and serial number of your machine?
Customer: I will grab that shortly!
JA: Anything else you want the agriculture mechanic to know before I connect you?
Customer: GHL06640J00606893

Hi,let's see if we can work together to get to the root of your problem! will try my best to help!

Where is click coming from? Starter area? Check the battery cables, may have wet connection from the snow, and now s shorting out the battery voltage from getting to the starter motor. Also check the negative battery cable connection to the frame.

Customer: replied 4 months ago.
Click is coming from dash. Electrical connections look (look) good. Will be trying to clean then up shortly. Due to temperature (-32C with windchill) phone will not work outside.Manual troubleshooting says connection in dash could be at issue.Starter was replaced 700 hours ago.
Customer: replied 4 months ago.
Won't be able to use phone, as my iPhone shuts off in these temperatures.

I'm thinking problem will be battery cable connections. on engine end. Can you get to the starter and see if it will jump at starter? If it works. relay in cab, not sending voltage to starter, but if it does not work, battery, cables, or starter!

I see question is still open, did you find problem? Please rate to close the question!

Customer: replied 4 months ago.
Hi Curtis, it was the starter. I could not work in -32C so I took it to a friend's shop. She is back up and running and I will make sure I do not return for work at the dealer that installed the faulty starter that lasted only 500 hours.Thank you for your time,Regards,
Karl from Edmonton Alberta Canada

Good job! Please rate to close and get me credit! Thanks.

Curtis B. and other Agriculture and Farm Equipment Specialists are ready to help you