How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Curtis B. Your Own Question
Curtis B.
Curtis B., Technician
Category: Agriculture and Farm Equipment
Satisfied Customers: 26026
Experience:  Technican turned service manager on multiple lines of equipment and rental equipment.
30244710
Type Your Agriculture and Farm Equipment Question Here...
Curtis B. is online now
A new question is answered every 9 seconds

I have a 2012 3800 hydrostat with 160 hours on it. The last

Customer Question

I have a 2012 3800 hydrostat with 160 hours on it. The last 2 times I've used it after about 20 minutes into cutting it will lose power all the way down to a n idle very quickly. It will crank back up, or a couple of times it will still idle . Keep going and it will do the the same thing a couple of minutes later. Any suggestions on where to start looking, fuel, coil ????fuel filter was changed 6 weeks ago,didn't notice any trash n bowl.
Submitted: 2 months ago.
Category: Agriculture and Farm Equipment
Expert:  Curtis B. replied 2 months ago.

Hi,let's see if we can work together to get to the root of your problem! will try my best to help!

Expert:  Curtis B. replied 2 months ago.

I'm sorry, what is 3800? Kubota? Toro? etc? Gas engine or diesel?I assume gas if it has a coil.??

Customer: replied 2 months ago.
Kubota, 3800 3 cylinder diesel, hydrostatic trans
Expert:  Curtis B. replied 2 months ago.

L3800 Kubota tractor. Have you made a test line from the fuel transfer pump inlet, back into the fuel tank filler opening and ran test to see if performance improves? I assume you changed the fuel filter after it had the problem, and it made no difference? As replacing the filter is always the first step!

Customer: replied 2 months ago.
I'll try checking lines for debris and tank ...... Chang filter as well and c what happens Thanks
Expert:  Curtis B. replied 2 months ago.

OK, running the test just does the test for you , without removing anything. And if all is well, then you haveto check the tank, and the outlet line and the lines and filter up to the fuel transfer pump.

Customer: replied 2 months ago.
I'll try that , I know with little info u have u think it's a fuel / trash problem or a pump ? Like I said it will run 30 min before it does act up and then several after that
Expert:  Curtis B. replied 2 months ago.

That makes me think that the tank ,may have debris that builds up as you run on the outlet tube .

Customer: replied 2 months ago.
Ok, thanks
Expert:  Curtis B. replied 2 months ago.

Thank you!

Expert:  Curtis B. replied 2 months ago.

I see question is still open, did you find blockage in the tank outlet?