How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Dan Your Own Question
Dan
Dan, Technician
Category: Agriculture and Farm Equipment
Satisfied Customers: 4373
Experience:  17+ yrs. shop and field experience with all major brands of heavy equipment, trucks and farm equipment - 1995 WyoTech graduate.
65405794
Type Your Agriculture and Farm Equipment Question Here...
Dan is online now
A new question is answered every 9 seconds

Same problem as above. Pump however is not new. Last

Customer Question

Hello
Same problem as above. Pump however is not new. Last 6 of my machine is 641131. I recently changed all filters. Was running fine cutting wheat. Started to unload and finished. Placed back in gear and won't move. Hydro charge pressure light is now on. Check the motor reservoir and it was low. Actually low to the point that it would not even register on the dip stick. Just filled it back up 2 weeks earlier. I have reel pressure and the separator will engage and run fine. I also have feeder house pressure for raising and lowering as well as power steering and it will also go into 4wd. Check all spline axle couplers and none are striped. Also have checked to make sure the system had no air built up inside the lines after a filter change. She's and older lady in combines but she's still my girl. Had a john Deere tech come out from my local store but
Submitted: 1 year ago.
Category: Agriculture and Farm Equipment
Expert:  Dan replied 1 year ago.
Hi my name is***** will be glad to help. Check the filters for signs of metal/debris indicating a pump or component failure. Make sure all levels are topped off. If metal is found and you have low charge pressure then you have a failed pump. Have your pressures checked and tested to see if they are within specs to confirm. Let me know