How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Ron Your Own Question
Ron
Ron, ASE Certified Technician
Category: Acura
Satisfied Customers: 33477
Experience:  35 years As a ASE Tech
7276279
Type Your Acura Question Here...
Ron is online now
A new question is answered every 9 seconds

2005 TSX. One of my headlight lens has moisture on the

Customer Question

2005 TSX. One of my headlight lens has moisture on the inside the clear lens. The out side were fogged.I buffed them clear. Then this. Is there a vent hole to allow air inside. I just bought the car. The light with moisture also had a problem with the hid was out and the turn signal out. I found them loose. They did work after fixing the metal wire. Also is yt ok to install a used a compressor. The one installed now Makes the engine vibrate. Or is there a fix?
Submitted: 1 month ago.
Category: Acura
Expert:  Ron replied 1 month ago.

Hello. My name is ***** ***** I am happy to assist you today. Give me just a moment to review your post, and I'll be right back with the help you need.

Expert:  Ron replied 1 month ago.

There is no vent for the headlamp assembly and in most cases if your getting moisture inside of them then either the seal on the bulb is leaking or there is a leak in the assembly and if that is the case the lamp assembly needs to be replaced. Was the engine vibrating before the used compressor was installed?

Customer: replied 1 month ago.
Not sure about the compressor. Just bought the car.
Expert:  Ron replied 1 month ago.

Are you sure its the compressor that vibrating or dose the engine seem to vibrate with the AC on?

Customer: replied 1 month ago.
vibrate when ac is turned on. Stops when off
The headlight whats the correct was to check. Doesn't seem to any cracks.
Expert:  Ron replied 1 month ago.

Have a look at the seal on the bulb socket to be sure its sealing. If its vibrating with the AC on I would suspect you may be dealing with a bad engine mount and or mounts.

Related Acura Questions