How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask thebesthonda Your Own Question
thebesthonda
thebesthonda, ASE MasterTechnician
Category: Acura
Satisfied Customers: 783
Experience:  26 years experience
14931499
Type Your Acura Question Here...
thebesthonda is online now
A new question is answered every 9 seconds

I have a 2002 acura mdx with the abs light on. i pulled

Customer Question

i have a 2002 acura mdx with the abs light on. i pulled etc's and all its given me is (unknown Code 20993) while driving when i press the brakes a little harder than normal I can feel thumping through the brake pedal as well as hear it from under the hood. can you tell me whats wrong?
Submitted: 4 months ago.
Category: Acura
Expert:  justinsbg replied 4 months ago.

Hi,

My name is ***** ***** I would be happy to help. Let me try to research this code. As a Honda/Acura mechanic of 10 years this code looks very unfamiliar.

Customer: replied 4 months ago.
Thank you. I been searching high and low for anything on this and no luck. How long till I hear from you?
Customer: replied 4 months ago.
Theres the code when i check it with my scanner
Customer: replied 4 months ago.
Relist: Incomplete answer.
Expert:  AZTechBrian replied 4 months ago.

Hello. The thump and the code are not related. The thumping/pulsating is most likely a warped brake rotor. During heavy braking the rotor gets hotter than during normal braking and the hotter temperatures are likely causing the rotor to become disfigured which gets better when the rotor cools a little bit. That code, is one I have never seen before. I have searched through a technician database as well that strange things like that often end up in in search for explanation, and there was absolutely no mention of it there either. Could you possibly check for codes using a different scan tool?

Customer: replied 4 months ago.
Ill try another scan tool. I know what rotors sound and feel like. This thump starts if im reversing out my driveway i can push hard on brake and the will be at full stop and the thumping thumps at least 10 times while pedal goes down a little bit each thump. I work on cars too. The sound of thumping is coming from the abs unit right infront of driver side firewall. Im gonna check snap on and see if its a snap on code. I graduated wyotech automotive degree program back in 2013. And this problem i cannot find anywhere.
Expert:  AZTechBrian replied 4 months ago.

Oh, so you have already determined the source of the thumping? I was unaware of that since it was not previously mentioned. As of now, it sounds now more like ABS activation, possibly a result of a bad tone ring or abs sensor? Have you scanned for ABS codes?

I figured you may be in the industry based on the fact that your scan tool is an ethos.

Please keep in mind that we only know what you tell us. We dont' know what you know, what you have done already, etc.

I don't think it's a snap-on code, but it's worth investigating I suppose.

Expert:  AZTechBrian replied 4 months ago.

I have owned a Modis for years, and on many occasions have been unable to obtain codes that my cheap auto xray was able to obtain. Just the way it goes sometimes. Check with another scan tool and let me know what you get.

Customer: replied 4 months ago.
Ok. Ill check
Expert:  AZTechBrian replied 4 months ago.

Great. And check for ABS codes. I have a feeling one of your tone rings or ABS sensors may be bad/cracked causing the ABS activation.

Customer: replied 4 months ago.
My other scanner is only pulling engine codes no abs.
Expert:  AZTechBrian replied 4 months ago.

The other scanner didn't pull up that odd code though, right?

Inspect all the tone rings and make sure they are all tight. A cracked one will be loose. Use your snap on scan tool and monitor the wheel speed sensors and when this happens, see if one of them seems to be acting different than the rest.

Customer: replied 4 months ago.
Ok
Expert:  AZTechBrian replied 4 months ago.

Did you get a chance to monitor the wheel speed sensors on your snap-on?

Customer: replied 4 months ago.
I did they seemed normal. But can only go 10 mph cause it say abs module will lose
Communication at 15mph.
Expert:  AZTechBrian replied 4 months ago.

The issue was ABS activation while reversing out of your driveway, right? were you able to get it to do that again while watching the sensors on the scan tool?

Customer: replied 4 months ago.
Does it in rev or drive everytime i stop
Customer: replied 4 months ago.
Wont do it when acNner is in data mode
Customer: replied 4 months ago.
Scanner*
Expert:  AZTechBrian replied 4 months ago.

it won't do it when your monitoring the abs sensors with the scan tool? When your coming to a stop, all the sensors read the same until your stopped?

Customer: replied 4 months ago.
Yessir
Customer: replied 4 months ago.
But as soon as i get out of data monitoring it does it
Customer: replied 4 months ago.
I gotta make the children some bfast and ill go do it again to confirm.