How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask sprinkles08 Your Own Question
sprinkles08, ASE Certified Technician
Category: Acura
Satisfied Customers: 21439
Experience:  ASE Master and Advanced level certified. Factory trained with 15 years dealership experience
Type Your Acura Question Here...
sprinkles08 is online now
A new question is answered every 9 seconds

It is not accelerating above 3000 rpm when it is floored, i

Customer Question

it is not accelerating above 3000 rpm when it is floored
JA: How old is the transmission? Have you checked the fuel filters?
Customer: i did not check the fuel filter
JA: What is the model/year of your Acura?
Customer: 99 acura tl
JA: Are you fixing your TL yourself? What have you tried so far?
Customer: cleaning the air intake and the unit under the trottle body
JA: Anything else you want the mechanic to know before I connect you?
Customer: thats it the diagonestic code is 0335 which is the crankshaft position sensor
Submitted: 2 months ago.
Category: Acura
Expert:  david craig replied 2 months ago.

Expert:  david craig replied 2 months ago.

Hi Im David, this was the same problem on a 99 a while ago. see if it helps you. sorry i have the entire conversation with it, but couldnt separate from the procedure.

Expert:  david craig replied 2 months ago.

do you still need assistance?

Expert:  david craig replied 2 months ago.


Expert:  sprinkles08 replied 2 months ago.

Hello and welcome to JustAnswer!

P0335 sets when there is an intermittent signal from the crankshaft position sensor. This could be the sensor itself, it's wiring or connections. Odds are the sensor itself is the issue and will need to be replaced. It would take some testing at the time the code is active to know for sure what si going on, but if you don't see any wiring or connection issues with the sensor then I would recommend replacing it with a factory part.