How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask thebesthonda Your Own Question
thebesthonda
thebesthonda, ASE MasterTechnician
Category: Acura
Satisfied Customers: 783
Experience:  26 years experience
14931499
Type Your Acura Question Here...
thebesthonda is online now
A new question is answered every 9 seconds

I have 03 acura cl type s, I just replaced the throttle

Customer Question

i have 03 acura cl type s, I just replaced the throttle body, because the plastic pulley broke and would no longer pull one of the cables. Well now it is idling very high, around 4000 rpms, and when I put it in park, it just drives without me even touching the gas pedal
JA: How many miles are on the car? What size is the engine?
Customer: 160,000
JA: What is the model of your '2000 Acura?
Customer: 3.2
JA: Are you hoping to fix this yourself? What have you tried so far?
Customer: i hope so, just replaced the throttle body
JA: Anything else you think the mechanic should know?
Customer: no
JA: OK. Got it. I'm sending you to a secure page on JustAnswer so you can place the $5 fully-refundable deposit now. While you're filling out that form, I'll tell the Acura Mechanic about your situation and then connect you two.
Submitted: 5 months ago.
Category: Acura
Expert:  Chad Farhat replied 5 months ago.

Hi my name is ***** ***** I will be assisting you today

Customer: replied 5 months ago.
it was a used throttle body
Expert:  Chad Farhat replied 5 months ago.

do you the cable connection route correctly can you send me a picture

you checked connector on TB ?

used is not a good idea on those accura

any check engine light on?

any fault codes

why u changed in first place can you tell me , did a code existed or u had lack of power

Related Acura Questions