How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask MASTER TECH Your Own Question
MASTER TECH, Acura Technician
Category: Acura
Satisfied Customers: 5716
Experience:  27 years of Honda training and a master Acura tech
Type Your Acura Question Here...
MASTER TECH is online now
A new question is answered every 9 seconds

TL: I have a 2004 Acrua TL. When i run the AC, cold air is

Customer Question

I have a 2004 Acrua TL. When i run the AC, cold air is not coming out of the vents. i ran the DTC diagnostic which generated a number of codes (I, K, L, N, and Q) which are related to the driver's and passenger's air mix and the passenger's mode control motor circuit. Can you recommend any next steps for me to take?
Submitted: 6 months ago.
Category: Acura
Expert:  MASTER TECH replied 6 months ago.
Hello welcome to just answer I am master tech and will be able to assist are you able to adjust the temp to hot and then back down to cold ?
Customer: replied 6 months ago.
When i adjust the temp to hot, then hot air comes out of the vents although the flow to the upper center vents seems a bit weak. When i adjust the temp to cold with AC 'on', the air is cooler but not cold. When i make the adjustments, i don't hear any type of switching or shifting sounds that i might expect to occur in the background. Also, when i ran in sensor input display mode, for sensor #6 (driver's air mix opening) an ER was generated. For #7 (passenger's air mix opening) the value wasn't fixed - it showed a number and then quickly showed a different one.
Expert:  MASTER TECH replied 6 months ago.
ok so the mode motor is working then if it's changing have you checked the freon level yet ? if so what are the high and low side temps while running and static pressures?
Expert:  MASTER TECH replied 6 months ago.
the mode motors are pretty quiet so not much back ground noise will be heard from them unless they start to to fail
Customer: replied 6 months ago.
I haven't checked the freon levels. How do you suggest that I do this as I've never done it before? Based on the DTC codes related to the mix control, wouldn't you begin to look at the root cause for them or are you suggesting that low freon could be the cause?
Expert:  MASTER TECH replied 6 months ago.
yes the system will not cool properly and will set codes.if your not familiar with this then you will need a shop to perform this as they have the a/c machines to perform this service.
Customer: replied 6 months ago.
how about a can of the R1234a with a guage? Would that help? I see that i can purchase at a local auto store or Walmart.
Expert:  MASTER TECH replied 6 months ago.
no you will need to get a high side reading also.the stuff thats sold at the parts stores to recharge contains about 70% oil and other sealers that damage system over a period of I don't recommend this at all.
Expert:  MASTER TECH replied 6 months ago.
but if that's the route you want to go then you will need to first get a pressure reading High and Low side thats a must.then if the system is low it will need to be evacuated and then you can recharge it with that method you mentioned.the freon we use in the machines is pure and contains no sealers or anything.we manually add pag oil to the system as needed.
Expert:  MASTER TECH replied 6 months ago.
Hello just checking in to see what progress you made since we last chatted
Customer: replied 6 months ago.
I've made an appointment with a local mechanic to take the pressure readings and determine next steps
Expert:  MASTER TECH replied 6 months ago.
ok sounds good I will wait for your results

Related Acura Questions