How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask MASTER TECH Your Own Question
MASTER  TECH
MASTER TECH, Acura Technician
Category: Acura
Satisfied Customers: 5716
Experience:  27 years of Honda training and a master Acura tech
10834442
Type Your Acura Question Here...
MASTER TECH is online now
A new question is answered every 9 seconds

My name is ***** *****. I have a 2007 Acura TSX that

Customer Question

Hi, my name is ***** *****. I have a 2007 Acura TSX that suddenly does not have power to the radio. Clock and Temp displays work fine, just no power to the radio itself. I have reset this before by pulling fuses 5,7, and 32 under the dash, and everything worked fine until I started the car this morning, and all of a sudden no power. I have disconnected the battery twice for 10-15 mins each time, pulled all radio related fuses I can find, with no success so far
JA: Thanks. Can you give me any more details about your issue?
Customer: not sure what else to add, you'll have to be more specific
JA: OK got it. Last thing — Mechanics for Acura generally expect a deposit of about $18 to help with your type of question (you only pay if satisfied). Now I'm going to take you to a page to place a secure deposit with JustAnswer. Don't worry, this chat is saved. After that, we will finish helping you.
Submitted: 9 months ago.
Category: Acura
Expert:  MASTER TECH replied 9 months ago.

hello welcome to just answer I am master tech and will be able to assist you today .

have you checked # ***** under dash fuse yet ? this is the radio fuse

Expert:  MASTER TECH replied 9 months ago.

here is the electrical section indicating the radio fuse

Customer: replied 9 months ago.
I just replaced the 10A #6 fuse, and still nothing. The anti-theft light is still blinking, if that helps
Expert:  MASTER TECH replied 9 months ago.

ok that does help.

was the fuse blown ?

Expert:  MASTER TECH replied 9 months ago.

here is the steps to recover the radio serial # ***** I can recover your radio code.

Customer: replied 9 months ago.
I have my radio code, i just don't get the unit to power up where it asks me for the code
Expert:  MASTER TECH replied 9 months ago.

ok then the radio will have to be removed so we can check for power and ground.

if these are present then the radio will need to be sent in for service.

did you want to remove the radio if so I can gather the directions.

Customer: replied 9 months ago.
the fuse was not blown on the #6 fuse, but i replaced it anyways, all mini fuses under the dash and the hood that i have found to correspond with the radio have been replaced as well
Customer: replied 9 months ago.
well considering i do not have a meter to check power, that won't accomplish much on my end, haha
Expert:  MASTER TECH replied 9 months ago.

ok

this is what will need to be done next since the system is a basic 2 fuse system.

power and aux and ground.

so the audio unit needs to be removed and then check power and ground at the connector with a volt meter

Expert:  MASTER TECH replied 9 months ago.

im sorry about that

think you can get some help from a neighbor ?

Customer: replied 9 months ago.
i read somewhere there is the possibility of trying a hard reset by removing the battery cables and touching them together for 20 mins with the key in the "on" position, is this worth trying?
Expert:  MASTER TECH replied 9 months ago.

semi correct the key needs to be off.

but you can try that.

no experience with the radio issue you have now normally it's the navi that does this.

but these are getting older so new things pop up all the time.

Customer: replied 9 months ago.
i guess i'll try the hard reset, seems the only other option for me since i don't have the proper tools to check power
Expert:  MASTER TECH replied 9 months ago.

ok.

wish their was a easier option but since this very basic the options are limited with out pulling the audio unit.

Customer: replied 9 months ago.
i'll let you know in a bit if it works
Expert:  MASTER TECH replied 9 months ago.

ok sounds like a plan

Customer: replied 9 months ago.
i tired the hard reset, and no success. i can only guess the unit itself has just died
Customer: replied 9 months ago.
tried*
Expert:  MASTER TECH replied 9 months ago.

it's very possible.

this is why the radio needs to be removed then power and ground checked.

if that is present then yes the audio unit will have to be replaced or serviced.

at that point it would be cheaper to buy a replacement audio unit from crutch field for a 1/3 or the cost

Related Acura Questions