How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask acramstr Your Own Question
acramstr, ASE Master Tech
Category: Acura
Satisfied Customers: 5241
Experience:  ASE master tech ,CA smog, ASE L1
Type Your Acura Question Here...
acramstr is online now
A new question is answered every 9 seconds

TL: heater not working o 1999 Acura tl. Blower works but no

This answer was rated:

heater not working o 1999 Acura tl. Blower works but no heat.

Hi Sir or Madam, welcome. I'm Steve. And I will be assisting you today. This can be a few different things so we will need to do some testing to get to the cause. First make sure the coolant is full and the car reaches normal operating temp. Then look behind the engine on the passenger side and watch the cable on the heater valve while someone turns the temp knob slowly from cold to hot (key on) and tell me if the cable moves the arm on the valve. Depending on if the cable moves we can go from there .


Customer: replied 3 years ago.

The car reaches normal temp.Hhowever the car is not here now as my wife took it to work. I will check this out later this afternoon.

ok, test it out and let me know what you find when you get a chance. IF the cable does not move try tapping on the air mix motor . It is under the dash to the left of the glove box here is a picture. Also see if it only moves when the knob or display is all the way to 90 .


Customer: replied 3 years ago.

Just checked the heater when she came home and no movement. Tapped the motor no movement.

ok, lets put the system in self test and see what it says here is how.

try this and let me know what happens.

Customer: replied 3 years ago.

I printed the instructions and no error code presented it self on the display. I did get some heat so maybe we did something. I will monitor it. Thanks for your help. If I take it to our technitation I can talk to him with some knowledge. Where is the excellent service button?

ok, If you didn't get any errors then the air mix motor could be the problem. That is the most common problem on these but I have seen controllers go bad but air mix motors are by far the most common failure when there are no codes. If there is anything else I can help you with let me know.
acramstr and other Acura Specialists are ready to help you

Related Acura Questions