How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask MASTER TECH Your Own Question
MASTER TECH, Acura Technician
Category: Acura
Satisfied Customers: 5716
Experience:  27 years of Honda training and a master Acura tech
Type Your Acura Question Here...
MASTER TECH is online now
A new question is answered every 9 seconds

2004 Acura TL: My a/c compressor wont engage.

Customer Question

My a/c on my 2004 Acura TL isnt working. The compressor clutch is not engaging and the engine cooling fans aren't coming on. The blue wire going to the a/c compressor is not getting power. I've already checked the relay, and I have continuity at the relay. I've also already ran a diagnostic on the climate control.

Submitted: 3 years ago.
Category: Acura
Expert:  HONDASERVICE7791 replied 3 years ago.

Hello and welcome to,


did you come up with any codes on the diagnostic?


when you checked the relay, did you check the relay and the socket where the relay goes? what signal are you missing? did you try switching the relays?

Customer: replied 3 years ago.

No codes on the diagnostic. I tried swapping the relays and then tested for continuity at the relay. I have 12 volts at pin number one.

Expert:  HONDASERVICE7791 replied 3 years ago.
so swapping the relays did nothing? which pin? if i send you a diagram will you be able to tell me the voltage readings you have?
Customer: replied 3 years ago.

Yes swapping the relays did nothing. I was using a schematic from the fsm, but if you want to send another schematic I can show you which pin I'm referring to.

Expert:  HONDASERVICE7791 replied 3 years ago.

ok here is a link to a troubleshooting tree for the clutch, this is helpful not only for the connection you have already checked but it also checks the other signals that should be at the relay including the ecm signal to the relay. let me know what you find


click here

Customer: replied 3 years ago.

Yes, I already have the exact same flow chart. It says not to use that one if the fans are also inoperative with the a/c on, which in my case they are inoperative. Just to clarify, I'm referring to the engine fans, not the blower fan in the cabin, that one is working just fine.

Expert:  HONDASERVICE7791 replied 3 years ago.
this seems to be pointing to a low freon condition. by chance has anyone evacuated and recharged the a/c to a full charge?? I don't see a mention on whether that has been done.
Customer: replied 3 years ago.

I evacuated the system, pulled a vacuum, and attempted to recharge, but without the compressor engaging it wouldn't take the full amount of refrigerant.

Customer: replied 3 years ago.
Relist: Inaccurate answer.
Expert:  MASTER TECH replied 3 years ago.

Hello welcome to just answer I am master tech and will be able to assist you today.

new expert here.

does the inside blower work in the cabin ?

Customer: replied 3 years ago.

yes blower in cabin is working fine.

Expert:  MASTER TECH replied 3 years ago.

sorry for the delay.

did you ohm the wire from the relay to the compressor wire?

sounds like the wire is open but a simple ohm test will confirm this.

also has this been involved in a accident ?

Customer: replied 3 years ago.

Haven't checked the wire for ohms, only for voltage. I will check and report with the results. Oh, and no, the car has not been involved in an accident.

Expert:  MASTER TECH replied 3 years ago.
ok just checking on the accident issue

Related Acura Questions